Dynamic Boost 2.0 on Linux (allocate more power to the GPU on Linux as well)

I have a MSI GS66 Stealth laptop with RTX 3070 laptop GPU (max. 95W) for my cuda and unreal engine development on Linux. I have ordered it by trusting your webpage describing the performance measures: Ampere—NVIDIA’s 2nd gen RTX architecture— Coming To Laptops January 26

I would like to achieve the maximum performance with the GPU on Linux as it is provided for Windows. On Windows 10 OS, there are options to select the Dynamic Boost to achieve the maximum 95W. However, on Linux it is not possible to tune the GPU driver to go beyond 80W.
Could you please instruct me how I can optimize the performance of the PC on ubuntu 20.04 (kernel version: 5.11)? The GPU driver is 470.42.01 (installed through cuda 11.4 toolkit).

So far I contacted the laptop manufacturer and they only support Windows OS related cases. Nvidia customer support directed me to the developer forums to further investigate the issue.
I would really appreciate if you provide a solution for the Linux OS as well.

Same problem will happen on Lenovo Y9000K,with 165W 3080. On Arch (5.15 kernel with 479 driver),3080 only allocate 115W.
I try to soulve the problem.If you have find a way,please tell me .Thanks!

You are not alone…

Please share the outputs of
cat /proc/driver/nvidia/gpus/0000:01:00.0/information
cat /proc/driver/nvidia/gpus/0000:01:00.0/power
Thanks.

Here is the output.For personal reason,I mask UUID
odel: Unknown
IRQ: 220
GPU UUID: GPU-c00a19c6-e6e2-32c0-0d77-
Video BIOS: 94.04.4f.00.1a
Bus Type: PCIe
DMA Size: 47 bits
DMA Mask: 0x7fffffffffff
Bus Location: 0000:01:00.0
Device Minor: 0
GPU Excluded: No

Runtime D3 status: Enabled (fine-grained)
Video Memory: Off

GPU Hardware Support:
Video Memory Self Refresh: Supported
Video Memory Off: Supported

Power Limits:
Default: N/A milliwatts
GPU Boost: N/A milliwatts