Nvidia RTX 3090 SW Thermal Slowdown always active

My RTX 3090 is running on the latest ubuntu drivers (installed using runfile) but immediately encounters SW Thermal Slowdown when under load. The GPU has adequate cooling and maintains an average temperature of 61 degrees celsius. The output from nvidia-smi:

The output from nvidia-smi -q -d PERFORMANCE:

The output from nvidia-smi -q -d CLOCK:

Interestingly, the Titan RTX while running at a much higher temperature does not encounter the thermal slowdown. I’ve attempted to manually set the clock speed of the graphics and vram but the RTX 3090 does not allow for that option. Please advise on possible solutions. Thank You!

I guess the memory is overheating which can’t be seen:
https://forums.developer.nvidia.com/t/request-gpu-memory-junction-temperature-via-nvidia-smi-or-nvml-api/168346/21

Would manually reducing memory clock speed or voltage be a possible solution?

Possibly. Memory voltage can’t be manipulated on Linux, AFAIK. Reducing memory clocks requires running an Xserver on the gpu with coolbits option.
Would of course reduce performance. I’d check for the add-on fan approach from the linked thread.