Nvidia-settings not able to set specifically on specific performance state

Sorry for a newbie questions.

I was wondering if anyone ever faced this kind of issues in ubuntu 22.04.2 headless mode, nvidia-settings doesn’t let me modify the GPUGraphicsClockOffset on specific performance state of P5.

I tried several times by changing the other performance state other than P5 then it works, but not on P5.

Steps to reproduce:

  1. I install nvidia-driver-525-server and nvidia-settings

  2. I have initialized the xorg.conf through the sudo nvidia-xconfig --cool-bits=28 --allow-empty-initial-configuration --enable-all-gpus command by the proper coolbits as well

  3. I am using crontab to automate the bash scripting, tried several ways, started with:

  • sudo X :0 to initialize the Xorg server, keep it on and use tmux to split the pane and start the overclocking script there

  • keep the lightdm active, by sudo systemctl enable lightdm

  1. both of the approach enables me to control the powermizer GpuPowerMizerMode, fan state GPUFanControlState GPUTargetFanSpeed but not with GPUGraphicsClockOffset

ps: tried also setting it to all performance level, but did not work GPUMemoryTransferRateOffsetAllPerformanceLevels, it did goes showing the output attribute is successfully changed but with error Unhandled integer attribute

All help is appreciated, thank you!

nvidia-bug-report.log.gz (1016.0 KB)