NVIDIA-SMI has failed on Ubuntu 22.10

Hi, I need help,

I am running ubuntu 22.10
I have disabled security boot
boot in my BIOS settings.
I’ve installed from ubuntu GUI Additional Drivers NVIDIA-515 driver metapackage

My system does not recognize the driver, hence don’t use it, please help


NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I am using Wayland
Gnore Version 43.1
Laptop Is Dell XPS 15 9510

nvidia-bug-report.log.gz (96.3 KB)

Kinda odd, you first had a working 525.78.01 driver, then you went to the incompatible “-open” version and now the nvidia gpu is turned off and inaccesible so no driver can load.
pci 0000:01:00.0: Unable to change power state from D3cold to D0, device inaccessible
Does it still work with Windows? Please also check for a bios update.

Thanks for the reply.
I don’t have windows to test with.
And I’ve checked for bios updates could not find any.

Do you have any other ideas on how possible I can fix it?
I am thinking of formatting and installing ubuntu 22.10 from scratch.

I don’t really know, might be a kernel bug or even defective hardware since it worked previously.
Maybe add the liquorix ppa to upgrade to latest kernel and check if the nvidia gpu comes alive.

Thanks a lot for a lot answers, can you send a link or some instructions on how to add the liquorix ppa to upgrade to latest kernel and?

Thanks again


THanks, again, I have tried this still no luck with enabling nvidia GPU

I’ve installed ubuntu from scratch, seems to work now with Nvidia driver 515 driver!