Nvidia-smi error with Ubuntu 20.04 on laptop


nvidia-smi gives me the following error

NVIDIA-SMI has failed because it couldnt communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

And the laptop’s graphics card description is given below:

lspci -nnk | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:9a60] (rev 01)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:24b8] (rev ff)

I tried installing older versions of the driver, but none have worked so far. Attached is the bug report.

I would appreciate any help in solving this issue.

nvidia-bug-report.log.gz (1.1 MB)

Your nvidia gpu is turned off. If you have bbswitch/bumblebee installed, please uninstall it.

I checked that both bbswitch/bumblebee are not installed.

I do see some error/failed messages during boot.

....... cant change power state from D3cold to D0 (config space inaccessible)

Friggin’ HP Zbook, Please try a 5.10 or a 5.15 kernel, I think 22.04 has that.

known incompatible are 5.13, 5.14 and 5.16.
5.17 and 5.18 have no reports. So you might try the liquorix ppa to get 5.18 and report back.

I tried rebooting after installing 5.15 linux kernel. It shows a blank screen, but if i switch to the text terminal (ctrl+alt+f2) and run nvidia-smi, it succeeds. Any idea what might have happened here?

Nevermind. Removing “nomodeset” from grub solved the gui issue.

Everything seems to be working fine now. Thank you @generix !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.