Nvidia-smi is not working well at ubuntu 20.04

nvidia-bug-report.log.gz (163.9 KB)

Status Info
PC HW : HP ZBOOK G8
OS : ubuntu 20.04
SW : Tried nvidia-driver-510, nvidia-driver-470
CMOS : Turned off “secure boot mode”
Symptom :
nvidia-smi is not working well with below a message.
“NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

Please give me advice for fixing this issue.

[ ANWSER : ]

Dmesg reports:

            [ 1.936890] nvidia 0000:01:00.0: can't change power state from D3cold to D0 (config space inaccessible)
      The ubuntu 5.13 kernel was released with bugs.
      Please check if you have a 5.11 kernel available in grub menu.
      You can also try using at least version 5.15 liquorix kernel from ppa:
         
https://launchpad.net/~damentz/+archive/ubuntu/liquorix

nvidia-bug-report.log.gz (88.7 KB)
Thanks for the kind guide.
The issue is not solved despite upgrading the kernel version to 5.16. Please refer to the attached log file.
If the kernel version was downgraded, the touchpad driver and wifi driver of HP ZBook G8 did not work,
so it could not be used. Any other solutions?
Thank you

For me, i found too, kernel 5.16 didn’t work.
That’s the reason i’ve gone back to 5.15.0-22.

This kernel works with nvidia-510.39.01.

But i installed with cuda-runinstaller.

My Distro is Ubuntu 21.10 !

Thanks for sharing valuable information!
Then, you are using ubuntu 21.10 with kernel 5.15.0-22. and installed nvidia-510.39.01 using cuda-runinstaller?

yes.

For sake of completeness, zbook g8 is too new for kernel 5.11.
I had also problems with my touchpad.

This kernel seems to work on older hardware only.

Thank you for your time. But I haven’t been able to solve this problem. In my Zbook, after upgrading to kernel 5.15.1, another problem occurs in nvidia driver installation. I hope that Nvidia and HP provide a solution that can use Ubuntu and the nvidia driver as soon as possible. It would be nice if someone else made and shared an example of successfully installing the nvidia driver on Zbook G8. Thanks again for helping me.

Ubuntu 20.04 comes with libc6-2.31.
Kernel headers 5.15 usual needs libc6-2.34 for compile with it.

If you will use a liquorix-kernel, there is one compiled for libc6-2.31,
as the logs say:
https://launchpadlibrarian.net/582829894/buildlog_ubuntu-focal-amd64.linux-liquorix_5.15-22ubuntu1~focal_BUILDING.txt.gz

On https://launchpad.net/~damentz/+archive/ubuntu/liquorix/+builds?build_text=&build_state=built
you can find under

amd64 build of linux-liquorix 5.15-22ubuntu1~focal in ubuntu focal RELEASE

the following packages:

linux-headers-5.15.0-18.1-liquorix-amd64_5.15-22ubuntu1~focal_amd64.deb (11.3 MiB)
linux-image-5.15.0-18.1-liquorix-amd64_5.15-22ubuntu1~focal_amd64.deb (60.7 MiB)

May be, with them you can overcome your problem.

I use a liquorix kernel with success…

Hey, do you happen to have these packages? Can you please upload them? I cant find it from the link