NVIDIA-SMI has failed

I know there are several posts on the subject. But my problem is still not resolved and I need a little help. To start, I have attached the result of the nvidia-bug-report.sh scriptnvidia-bug-report.log.gz (93.1 KB)

I have two video screens. Until the day before yesterday, everything was working fine. But when I tried a compilation with mypy-cross (converter into bytecode of a CircuitPython project for a microcontroller), my PC station froze. Unfortunately I did a cold reboot and this led me to enter the ‘nomodeset’ parameter in the grub command line. This allowed my workstation to restart but with only one screen! Obviously, the GeForce GTX 1660 graphics card is detected. The lspci command | grep VGA gives as result:

01:00.0 VGA compatible controller: NVIDIA Corporation TU116 [GeForce GTX 1660] (rev a1)

But the nvidia-smi command gives:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

As actions:

  1. I have made sure that Secure Boot is disabled in my BIOS.
  2. I have completely reinstalled the package for nvidia-470. It didn’t change anything.
  3. I downgraded to the nvidia-460 package and it didn’t work.

This is where I am.

My PC:
Operating System: Kubuntu 21.04
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.0-37-generic
OS Type: 64-bit
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-7400 CPU @ 3.00GHz
Memory: 15.6 Gio of RAM
Graphics Processor: llvmpipe

** EDIT **
I started my system using Kubuntu on a USB key. The graphics card has been detected and the second display has been detected. So the problem on my workstation is either a configuration problem or a driver problem.

Thanks in advance for any help.


Error! Your kernel headers for kernel 5.11.0-37-generic cannot be found.
Please install the linux-headers-5.11.0-37-generic package,

I guess the message from the installer says it all.

Right in the target! Thank you very much generix. Now I think that the problem does not originate from my compilation with mypy-cross but rather from the cleaning that I did a few days earlier in the kernels. By dint of accepting kernel updates, my /boot partition fills up and comes a time when nothing can be added to it. So I cleaned up and I remember having to delete files by hand. The error must come from there! To conclude on your solution. I removed the ‘nomodeset’ from the grub command line and erased the xorg.conf file created I do not really know what manipulation.

Best regard