nvidia-smi is showing only one GPU

I’ve installed cuda 9.1 with the driver 387.34. When I run any default cuda tests and nvidia-smi, results are showing only one GPU.

Output of nvidia-smi

root@wave-233:~/NVIDIA_CUDA-9.1_Samples/1_Utilities/p2pBandwidthLatencyTest# nvidia-smi 
Fri Feb  2 16:28:06 2018       
| NVIDIA-SMI 387.34                 Driver Version: 387.34                    |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  Tesla K40c          Off  | 00000000:DF:00.0 Off |                    0 |
| 23%   44C    P0    65W / 235W |      0MiB / 11439MiB |     98%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|  No running processes found                                                 |

output of lspci

root@wave-233:~/NVIDIA_CUDA-9.1_Samples/1_Utilities/p2pBandwidthLatencyTest# lspci | grep NVIDIA
de:00.0 3D controller: NVIDIA Corporation GK110BGL [Tesla K40c] (rev a1)
df:00.0 3D controller: NVIDIA Corporation GK110BGL [Tesla K40c] (rev a1)

But I can see some issue in the dmesg. Following error is coming on dmesg everytime I ran default tests, including nvidia-smi.

[  182.717961] NVRM: RmInitAdapter failed! (0x26:0xffff:1115)
[  182.718267] NVRM: rm_init_adapter failed for device bearing minor number 0

Either your driver install or the GPU itself is broken.
Depending on how you installed the driver, nouveau might be getting in the way. Or you may have a new linux kernel like 4.13 which is problematic with any drivers prior to 390.12

Thank you again txbob,

I was trying to install Cuda 9.1, the default driver for it is 387.
Is it ok if I install driver- 390 for Cuda 9.1?

btw, This is my uname-r output

Linux ubuntu-223 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

That’s a 4.4 kernel and should not be a problem with any driver.

Yes, you can use 390.12 with CUDA 9.1