Nvidia wayland linux

For some reason nvidia proprietary drivers are not loading with arch + KDE + wayland. I already tried nvidia_drm.modeset=1 but it just makes arch stop booting.

Try adding both these options to the cmdline

nvidia_drm.modeset=1 nvidia_drm.fbdev=1

what is the difference about put these flags in grub and put into /etc/modprobe.d/foofile.conf options nvidia_drm modeset=1 fbdev=1 as content?