Cannot boot with any driver version on Ubuntu 19.04

I am running 19.04 with kernel 5.0.0-16-generic. I only have Ubuntu installed. I have a Nvidia 1070 graphics card. After a recent update, I was unable to startup. The process freezes with a blinking cursor after the message “bpfilter started”.

The only solution I could find was to remove all nvidia drivers (after trying to install 430, 418, 410, 396, and 390 from the graphics ppa). Now I am only using only X. HDMI output and any type of graphic intensive work is impossible, which is frustrating as I am a game developer.

I have already disabled secure boot. I tried disabling UEFI boot mode but then my boot hangs on a blinking cursor immediately after the bios screen. I believe my boot partition is EFI. I have attempted to disable Wayland in gmd3. Here is my /etc/gdm3/custom.conf:

# GDM configuration storage
#
# See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon]
# Uncomment the line below to force the login screen to use Xorg
WaylandEnable=false

# Enabling automatic login
#  AutomaticLoginEnable = true
#  AutomaticLogin = user1

# Enabling timed login
#  TimedLoginEnable = true
#  TimedLogin = user1
#  TimedLoginDelay = 10

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
# More verbose logs
# Additionally lets the X server dump core if it crashes
#Enable=true

How can I boot with my graphics card functioning? How can I safely install the nvidia drivers?

Please install the nvidia drivers from ppa, try to boot. If it hangs, reboot to recover and run
sudo journalctl -b-1 --no-pager >journal.txt
and attach the output file. Attaching files:
Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Done.
journal.txt (299 KB)

It’s an Optimus system and you’ve ‘nomodeset’ kernel parameter set which is killing the igpu, please remove it and if it still doesn’t work, please run nvidia-bug-report.sh as root from recovery and attach the output file ‘nvidia-bug-report.log.gz’.

Thank yo so much for your patient help. Removing nodemodeset allowed me to boot sucessfully. I think I know what happened:

  1. My installation wasn’t working due to secure boot.
  2. I enabled nomodeset to sucessfully start without X originally to remove drivers.
  3. After disabling secure boot, allowing the drivers to work, I forgot to enable it, thus blocking them again… Apologies for the mistake.

I am now successfully running 4.30. However, I did have another issue. My external HDMI monitor was totally unrecognized. I found the solution in the second answer of this ask ubuntu question: https://askubuntu.com/questions/1105332/external-monitor-not-working-ubuntu-nvidia, which explains it may be necessary to switching to lightdm, which worked for me. The first answer, which suggests commenting out the ‘nvidia-drm modeset=1’ had no effect. Is there something else I should do here, or should I just stick with lightdm? Do I need to make another thread about this?

Known GDM bug, just stick with lightdm.

Thanks so much for everything.