Boot hangup after installing Nvidia drivers 390.48 released by Ubuntu, Can't get into root shell either as Keyboard and System Hangs up

Hi

I installed Xubuntu Beta 2 18.04 two days back from now. It came with Linux Kernel 4.15.0.13. After updating all the packages it installed 4.15.0.15. Then I rebooted the system.

I installed Nvidia drivers for my Nvidia 1050Ti card and it installed 390.48 drivers in my system. When I rebooted, system never booted. So, I tried to boot into the recovery mode so I could remove Nvidia modules, but when the screen opened with menus, then the keyboard stopped working. It seemed as if system hung up.

So, I restarted using the earlier kernel which didn’t had Nvidia modules and using that I was able to boot into XFCE, and then I removed all the Nvidia modules using “sudo apt-get remove --purge nvidia*”.

After rebooting I was able to boot using the kernel 4.15.0.15 again.

I googled for this, and someone said that “this bug” is fixed in 390.48 but that’s what Ubuntu installed in the first place.

I thought may be the problem was with kernel so, I updated to 4.15.17 kernel using “UKUU” utility but the same problem persisted. Again after installing drivers system didn’t booted.

I can’t move on to kernel 4.16 as my WiFi drivers doesn’t support that kernel version as of yet.

Please help!!

Here’s the log

https://paste.ubuntu.com/p/dsCcypG8dr/

My PC Config :
Intel Core i3 4160,
12 GB DDR3,
GA-H81M-S (rev. 1.0) Motherboard,
Xubunbtu installed on 120GB Kingston SSD
1 TB WD HDD
Nvidia 1050Ti Graphics Card

Problem Solved!!

I read on some other thread in the same site that “secure boot” could be a problem, so I disabled it from BIOS and booted the linux, installed driver and it still DID NOT worked.

My Motherboard BIOS is latest but is still buggy.

So, for last try I re-installed xubuntu 18.04 beta 2 in legacy mode and then installed drivers again, and then IT WORKED!!

Buggy BIOS in my motherboard is the culprit. Problem with it is, if I even disable a particular HDD in BIOS it still shows up in windows as well as in Linux.

Probably same thing happened in it when I disabled secure boot??? Or may be linux had problems with some other setting related to UEFI in BIOS. Either way, installing xubuntu in LEGACY mode solved my problem!!

Thank you all!!

After disabling secure boot in bios, grub will still enforce the secure chain on kernel and modules so just reinstalling the driver won’t suffice. So you will either have to replace grub-efi-amd64-signed with the unsigned grub or simply reinstall the system as you did.
So an efi reinstall most likely would have succeeded, too.
It is also possible to have secure boot enabled but disable module checks with ubuntu, during install select ‘install third party software’.
Just as explanation in case somebody else is looking for a solution.