Trouble installing Nvidia drivers because of the disabled secure boot (Ubuntu 18.04)

Hello, I need to update my Nvidia drivers in Ubuntu 18.04.3 LTS, but while installing drivers using below command

$ sudo apt-get install nvidia-driver-410

I am getting this message

...
Secure Boot not enabled on this system
...

I tried to enable the secure boot from BIOS but I am stuck with this error

Disable the CSM in Setup. Repeat operation after Reboot to ensure UEFI Video (GOP) driver is operational

https://i.postimg.cc/rFX81p3K/secure-boot2.jpg

Actually recently I have updated my BIOS as I was upgrading my CPU, I think after updating the BIOS some settings have been changed

I am not an advanced user, this is the first time I came across this issue and I don’t want to mess up with the BIOS settings, can anyone help me resolve this issue

Motherboard: Asrock B360M Pro 4 [https://www.asrock.com/mb/Intel/B360M%20Pro4/index.asp]

Note: I also have Windows 10 installed on other SSD and it works fine, I have installed all the drivers and benchmarked it without any problem

The message you’re getting is informational. It should not prevent the NVIDIA drivers from working.

In fact enabling Secure EUFI boot makes loading NVIDIA drivers impossible in many cases because they are not digitally signed.

Please leave the Secure Boot option disabled and you’ll be fine.

Eventhough driver gets installed with warning message “Secure Boot not enabled on this system”, when I issue “nvidia-smi” command I get this error message “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running”

include a copy of an nvidia-bug-report.log.gz file, which can be generated with the nvidia-bug-report.sh script shipped with the NVIDIA Linux/FreeBSD graphics drivers and installed in your PATH; the log file will be placed in the current working directory. Attach the log file by hovering your mouse over your forum post and then clicking the paperclip icon that appears.

Hello @birdie,Yes you were right, I left secure boot disabled. It turns out problem was something else, Actually after installing Nvidia driver I was also installing CUDA toolkit which has some built in old Nvidia drivers, so while installing CUDA nvidia drivers was getting corrupted. Hence first I installed Nvidia driver then installed CUDA by not allowing it to install Nvidia drivers and the problem got resolved.