NVIDIA X Server hangs computer after Fedora update

After a recent Fedora 10 package update, I can no longer run the “NVIDIA X Server Settings” program without the computer completely freezing (mouse, keyboard, screen).
The same result occurs when I run it from the command line as ‘/usr/bin/nvidia-settings’.
I have tried reinstalling the driver (Version 190.18) but it doesn’t help.
Although the display seems okay for most other apps, it also crashed when I tried to activate the Accelereyes Jacket toolkit in Matlab using ‘gactivate’.

Hardware is Velocity Micro box with 4 Tesla C1060s and a GEForce 8400 GS.

Any advice is appreciated.

The Nvidia driver kept causing a Fedora kernel failure which made it impossible even to reinstall the Nvidia cudadriver.
The solution was to boot from the Fedora 10 image CD and select update system when prompted by the Anaconda installer.
Then I could reinstall the cudadriver 190.18 from the command line and everything worked again.

Still unsure how the initial problem was caused but it came after a Fedora security package update that caused the system to “forget” the cudadriver, which required a driver reinstall.
I may not have done a reboot after the driver reinstall that time, but rather restarted with an init 5 command.