startx fails after cuda driver installation on Fedora 10


I will install the cuda driver on Fedora 10 (Kernel: I tried a few driver versions and also the recommended driver from cuda webpage but everytime after installation
I am not able to start the X-server and I have to install again fedora, this is annoying.
Please, If someone had the same problems please contribute your solution.
At least which CUDA driver version is compatible with my kernel version



If Fedora does not supply an NVidia driver that works with CUDA, you have to uninstall any and all NVidia drivers from the Fedora package system before installing the one you download manually. Besides that, all recent drivers should work AFAIK.

Thank you, I’ll give it a try.

actually I installed Fedora new and tried to install the driver on a fresh recently installed Fedora 10.

Could that be, that a fresh Fedora 10 installation contain nvidia drivers by default.

Thanks again

At least Ubuntu has some stuff that gets in the way, even after a fresh install. If I remember correctly. It’s entirely possible that Fedora does something like that.