NVPARSER: HEVC: Seeking is not performed on IRAP picture

Device Specification
**• Hardware Platform (Jetson Nano)
**• DeepStream Version 6.0
**• JetPack Version 4.6.1
**• TensorRT Version

I am trying to run a deepstream application on my device. I get following issue while running my application with my current rtsp.
NVPARSER: HEVC: Seeking is not performed on IRAP picture
I have tested my rtsp with multiple methods. It is working only with cv2 with ffmpeg as a backend with other methods it is giving errors.
The methods I have tried are following.

  1. With ffplay and ffmpeg errors are following.

  2. With gst-launch-1.0 / gst-play-1.0 / gst-discoverer-1.0 I am getting same error as one in deepstream Application.

Can someone give me solution to this issue or just explain me the reason for this issue to occur is it related to my rtsp source or some other issue is happening.

Can you share your RTSP stream?


No one can access such LAN address. Can you capture the stream with tool?

yeah I have tried to capture the stream with different tools that I have mentioned in earlier comment and its only being captured using cv2 and is failing with others

I mean there must be something special in the stream. So please record the stream for us to analysis.

from threading import Thread
import cv2

class RTSPVideoWriterObject(object):
def init(self, src=0):
# Create a VideoCapture object
self.capture = cv2.VideoCapture(src)

    # Default resolutions of the frame are obtained (system dependent)
    self.frame_width = int(self.capture.get(3))
    self.frame_height = int(self.capture.get(4))
    # Set up codec and output video settings
    self.codec = cv2.VideoWriter_fourcc('M','J','P','G')
    self.output_video = cv2.VideoWriter('output.avi', self.codec, 30, (self.frame_width, self.frame_height))

    # Start the thread to read frames from the video stream
    self.thread = Thread(target=self.update, args=())
    self.thread.daemon = True

def update(self):
    # Read the next frame from the stream in a different thread
    while True:
        if self.capture.isOpened():
            (self.status, self.frame) = self.capture.read()

def show_frame(self):
    # Display frames in main program
    if self.status:
        cv2.imshow('frame', self.frame)
    # Press Q on keyboard to stop recording
    key = cv2.waitKey(1)
    if key == ord('q'):

def save_frame(self):
    # Save obtained frame into video output file

if name == ‘main’:
rtsp_stream_link = ‘rtsp://user1:cctv2020@’
video_stream_widget = RTSPVideoWriterObject(rtsp_stream_link)
while True:
except AttributeError:

Please provide the stream for analysis.

here’s the link for recording of my stream

Is there any transcoding of the stream when you record this video?

No I dont think so. I have used the code which I have posted in post above to record this using cv2

is there any more information you need from my side ?

The stream is MJPEG. Can you try the following pipeline in your Jetson board?
gst-launch-1.0 rtspsrc uri=rtsp://xxxxxx ! rtpjpegdepay ! jpegparse ! nvv4l2decoder mjpeg=TRUE ! nvvideoconvert ! nv3dsink

so I have tried to use this pipeline and I am getting this error

and when I try to replace nvvideoconvert with simple videoconvert I get the following error

Have you installed the DeepStream SDK correctly?

yes I have DeepStream Version 6.0

What is the result of “gst-inspect-1.0 nvvideoconvert”?

it gives No such element or plugin ‘nvvideoconvert’

So the DeepStream is not installed correctly. Please follow Quickstart Guide — DeepStream 6.0.1 Release documentation to install DeepStream and the dependencies.

I am using Deepstream NGC Container ( DeepStream-l4t container 6.0 samples ). I am getting this while using the following you mentioned above.

gst-launch-1.0 rtspsrc location=“rtsp://user1:cctv2020@” ! rtpjpegdepay ! jpegparse ! nvv4l2decoder mjpeg=TRUE ! nvvideoconvert ! nv3dsink