NVTTE 2024.1.0 mip filter parameters not read from command line

When using the NVTT Exporter from the GUI, and overriding any of the default filter parameters, and saving the preset to .dpf, the following happens:

Expected Behavior:

DDS files that are compressed using the GUI should match those that are built from the command line with the same saved .dpf preset.

Observed, incorrect behavior:

Setting any filter parameter for the kaiser filter from the command line results in a blurry mess in the mips, and the parameters specified via cmd line have no effect on the mip filter.

While changing these parameters in the GUI produce correct results.

Reproduction Steps:

Use the .dpf parameters below for a sharp Kaiser filter:

--mip-filter kaiser --mip-filter-width 4 --mip-filter-param-1 4 --mip-filter-param-2 2 

The result is blurry mess in the .dds file’s lower mip levels. Changing the filter parameters has no effect on the output.

Set these settings in the GUI, and the GUI correctly creates the .dds file, and responds to changes to the filter parameters.

Will gladly provide screenshot results and input file used if this helps debugging the issue.

Hi @mysterme, thanks for reporting this bug! Looks like the root cause of this one was that both --mip-filter-param-1 and --mip-filter-param-2 affected parameter 1, instead of the second one affecting parameter 2. Because the second mip filter parameter’s applied after the first, its value of 2.0 overwrite the first parameter’s value of 4.0 – which means that the result was equivalent to using a Kaiser filter with an alpha of 2.0 and a stretch of 0.5!

I’ve submitted a fix for this, which will be included in the next version, and I’ll update this thread when it’s released. Thanks again for reporting this one!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.