Mipmap atlas options don't work from command line

The mipmap atlas options do nothing when used from the command line even though they are listed in help.
nvtt_export.exe --mip-extract-from-atlas --num-mips-in-atlas 3 --no-mips

I tried all option variants --atlas-mips, --num-mips-in-atlas, --extract-from-atlas, --mip-extract-from-atlas but none worked

I also tried saving a preset file (dpf) from the UI for use at the command line with -p / --preset option. But this doesn’t work at all. In fact it doesn’t even check if the config file exists. -p “” is valid.

Hi @Nicholas-B, thanks for reporting this! I can confirm that this is a bug in 2023.1.0-2023.2.0; I have a fix for it in the pipeline, and it’ll be included in the next version. This also affected the --texture-type flag. Although the standalone version and plug-in now use the same command-line like syntax for their settings, this doesn’t seem to affect the Photoshop plug-in.

In case it’s interesting, here’s a brief description of what’s going on! When the standalone version loads a file, it automatically sets the texture type and atlas parameters based on the dimensions of the image. For instance, if it detects that the input file was a cubemap with 5 mips and 3 elements, it’ll set “Texture Type” to “Cube Map”, automatically unpack the image to an atlas, enable “Extract From Atlas”, and set “Number of Mips in Atlas” to 5, and “Number of Array Elements” to 3. This makes it so that if you load a cubemap, it automatically switches to a cubemap view (and similarly, loading a 2D texture switches to the 2D view).

The issue is that this code path also ran when nvtt_export was invoked via the command line, and command-line parsing occurs before image loading. So nvtt_export would read --num-mips-in-atlas 3, then overwrite --num-mips-in-atlas with the number of mips in the input image (which is 1 for most image types like .png and .jpg, since they don’t have mips).

Thanks again for reporting this bug!


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Hi @Nicholas-B ! Updating this thread to let you know that we’ve released NVIDIA Texture Tools Exporter 2023.3.0, which fixes this bug – the command-line mode no longer resets --num-mips-in-atlas, --atlas-mips, --extract-from-atlas, --mip-extract-from-atlas, and --texture-type` after parsing the command line.

Thanks again for reporting this!