Nvidia texture tools keeps crashing and freezing when uploading a picture or when saving

this started to happen recently it was fine before but all of a sudden it suddenly stopped working

i tried using the window command prompt and this popped up
(installed standalone version)

Hi @namennayo ! For the Windows command prompt, could you try using the full path to the executable, like this?

"C:\Program Files\NVIDIA Corporation\NVIDIA Texture Tools\nvtt_export.exe" --help

The image in the first issue is really interesting – it’s as if Photoshop started the plugin, but the plugin didn’t receive any images. I’m having trouble reproducing the issue on my side, but maybe we can narrow down what could be causing it:

  • Which version of Photoshop are you using? This info appears in Help > About Photoshop…
  • Does this happen with all images, or with only some images? If it occurs with only some images, would it be possible to send me a Photoshop file that makes this happen here, via DM, or via email (texturetools@nvidia.com)?
  • If you run dxdiag and select the Display tab, what GPU and driver version do you see listed here?


hey thanks for replying
heres the results i got
tried the prompt first and got this pop up instead

photshop version is 2018 it was working fine

i tried even with a blank 256 x 256 and it still crashes

it was all working fine till recently

heres dxdiag

Ah! Make sure you have quotes around the path, like this:

"C:\Program Files\NVIDIA Corporation\NVIDIA Texture Tools\nvtt_export.exe"

Otherwise, Command Prompt will parse it as if there were multiple strings separated by spaces, like this:

C:\Program Files\NVIDIA Corporation\NVIDIA Texture Tools\nvtt_export.exe
^          ^            ^                  ^       ^
0          1            2                  3       4
Parsed as:
Program to run: C:\Program
Argument 1: Files\NVIDIA
Argument 2: Corporation\NVIDIA
Argument 3: Texture
Argument 4: Tools\nvtt_export.exe

Additionally, there’s no need to add start to the front; since nvtt_export is a GUI app, it runs asynchronously.

Here’s an example of how to run nvtt_export with an argument to show its command-line options:

Or to launch the GUI, run it without arguments:

i tried it still got the same result it crashes
ah i see you mean copying the whole thing my bad

hey what is the argument thing for?

sorry for being annoying just noticed this, could this lead to anything?

It’s a neat command-line interface we have that allows you to compress images using nvtt_export without launching the GUI at all!

For instance, if you run

"path/to/nvtt_export.exe" input1.png --format bc7 --output output1.dds

(where you replace "path/to/nvtt_export.exe" with "C:\Program Files\NVIDIA Corporation\NVIDIA Texture Tools\nvtt_export.exe"), it’ll compress input1.png using BC7 into a DDS file named output1.dds.

Every option in the GUI has an equivalent command-line option; so, for instance, if I wanted to

  • load input2.jpg
  • turn off CUDA acceleration
  • interpret it as a cubemap
  • convert it to grayscale
  • compress it to BC1
  • save it to a KTX2 file

I could run

"path/to/nvtt_export.exe" input2.jpg --no-cuda --texture-type cubemap --to-grayscale --format bc1 --output output1.dds

I wonder if adding --no-cuda and using the command line might fix the display issue as well? The GT 740M is old enough (it has a CUDA compute capability of 3.0, while our minimum compiled kernel version is 3.2) that the Exporter should fall back to CPU processing. But maybe the logic to fall back from GPU to CPU processing isn’t working correctly in this case? I should be able to find a similar GPU here and experiment to see if this is the case.

Hope this helps!

Ah, that absolutely helps, that’s fascinating! I have a good idea of where this error is coming from now; this is because 2023.2.0 added additional error-checking around CUDA kernels, but the errors aren’t being propagated to the logic to make it switch over from GPU to CPU processing.

I think this might work - could you try this and tell me if it does?

  1. Open the Texture Tools Exporter standalone, then click “Load Preset” and load this preset file:
    no-cuda.dpf (9 Bytes) - this manually tells the Exporter not to try running CUDA kernels.
  2. Then load your image.

If it works, I think you’ll then be able to see the image display correctly, and image processing and compression should work in the GUI.

how do you turn off cuda
and i copied the path but the command said

omg it works on the standalone but when i try in photoshop it just crashes
so how do i make it load the no cuda preset everytime i save using photoshop

Ah, you’ll need to replace "path/to/nvtt_export.exe" with the full path to nvtt_export on your system, and use images that exist - like if you have an image at C:\Users\MY COMPUTER\pebbles.png, you’d run

"C:\Program Files\NVIDIA Corporation\NVIDIA Texture Tools\nvtt_export.exe" "C:\Users\MY COMPUTER\pebbles.png" --no-cuda --format bc7 --output "C:\Users\MY COMPUTER\pebbles.dds"

(I write path/to/nvtt_export.exe because users can choose to install nvtt_export in different places, so not everyone has it under C:\Program Files\NVIDIA Corporation\NVIDIA Texture Tools).

how do i do that ? do i do that in the window command everytime or this is just a one time fix?

when a newer update comes out could they make something that helps with my problem?


I haven’t figured out a workaround that would work for Photoshop, yet, unfortunately. Invoking a custom Photoshop Action with --no-cuda is probably too tricky.

My current plan is to fix the underlying bug where CUDA errors aren’t propagated correctly on GPUs with compute capabilities below 3.5; then in the next version you should be able to run nvtt_export without needing to specify --no-cuda, as the switchover will be fixed - apologies for the wait!

(I did think of one thing, although I’m not sure yet if it will work. In Photoshop, if you click “Display Compressed” in the top-right, what happens?)

Generally, yes, you’ll need to specify the full path to nvtt_export.exe, unless you add C:\Program Files\NVIDIA Corporation\NVIDIA Texture Tools PATH environment variable, which adds that folder to the list of places Command Prompt looks to find .exe files. Here’s a guide on how to do that: Add to the PATH on Windows 10 and Windows 11 | Architect Ryan


display compressed in the standalone or in photoshop cus in photoshop it doesnt even let me do anything it just freezes in the standalone it just loads up fine with the “no cuda preset”
by any chance you got an older version of the nvtt for me to try to see if that works or not
hope the next update comes out soon and fixes this problem cus i really rely on the dds converter that you guys made

Got it, thanks! Here’s the direct link to the previous 2023.1.0 version - this should work if you’re logged in and can access the current version: https://developer.nvidia.com/downloads/designworks/texture-tools-for-photoshop/secure/2023.1.0/nvidia_texture_tools_for_adobe_photoshop_2023.1.0.exe

I’ll update here once we release the next version. Thanks again for reporting this!