First DDS loading in PhotoShop crashes

I’m using Photoshop installed via Creative Cloud Desktop on Windows 10.
When I loaded the DDS file immediately after starting PhotoShop, an error was displayed and PhotoShop closed.

  • Date of first confirmed occurrence
    December 1, 2022

  • Version to reproduce
    PhotoShop CC v24.1.0, v24.0.1, v24.0

  • Reproduction steps
    1, After starting PhotoShop, open the DDS file.
    2, After a while, an error window appears.
    3, PhotoShop crashes after closing its window.

However, the following procedure does not cause this problem.

1, Check Enable legacy “Save As” in File Handling in PhotoShop Preferences.
2, Attempt to save a new or existing file in DDS format via “File > Save As”.
3, NVIDIA dds Format window (attached image) is displayed.
4, Press either Save or Cancel button on the window.
5, Open the DDS file.

— Below is my environment.

  • License authentication method
    Named User License

  • OS Version
    Windows10 Version 21H2 (OS Build 19044.2251) 64bit, x64 base processor
    Due to business restrictions, I am unable to test the update to Windows 10.

  • Hardware information
    Computer model name: Endeavor
    CPU: Intel Core i7-9800X
    RAM: 64GB
    Graphics Board: NVIDIA RTX 2070 SUPER
    Graphics Driver: 527.56

It is convenient to be able to open the DDS file immediately after starting PhotoShop.
Thank you.

Hi osakmasa! Thank you for the detailed system information and reproduction steps!

I’ll try to see if I can reproduce this on my end. Do you happen to know if it crashes only when loading a specific DDS file (for instance, does it have to be a specific size or format - even better, could you attach a file I could test with), or does any DDS file work?

Thanks!

–Neil

Thank you, nbicford.

Any DDS occurred. For example, the following procedure also occurs.
1, Create a new 256x256 file in Photoshop
2, Save as DDS with default settings (DXT1, RBG 4bpp | no alpha, 2DTexture, Generate Mip maps)
3, Restart Photoshop
4, Load the DDS saved in 2

Thank you osakmasa!

Two additional questions - in the first message, you mentioned a screenshot of the DDS Format window was attached, but it looks like it didn’t upload - would it be possible to try re-uploading it?

As a second question, if you go to Help > About Plugins, do you see an entry labeled “D3D/DDS”, like this?

image

If so, then what’s probably happening is that the system might have both the legacy (2013) version of the Texture Tools Exporter, and the new version (2021) installed at the same time. Because the legacy version has a name that comes first alphabetically, Photoshop tries to open .dds files with the old version, which crashes. (I tried installing the legacy plugin at the same time as the new one to create this screenshot, and successfully reproduced the crash you described.)

The solution would be to uninstall the old version (it’s listed as “NVIDIA Photoshop Plug-ins 64 bit” in Control Panel > Programs and Features). Alternatively, it’s possible to uninstall only the file format loader from the old version by deleting C:\Program Files\Adobe\Adobe Photoshop 2023\Plug-ins\File Formats\dds64.8bi. Then D3D/DDS should no longer show in the Help > About Plugins menu, and the next time you load a DDS file, Photoshop should use the new version of the DDS loader and the DDS file should load successfully (or in the event it’s a file it can’t handle, it should not crash).

Hope this helps!

Thanks again,

–Neil

Sorry, forgot to attach a screenshot. It looks very familiar to you.

Thank you for confirming the reproduction and explaining the workaround.

I have understood the cause, but I can’t personally test it because my company has its own way of managing plugins. Therefore, I would like to report this solution to the appropriate department within my company for confirmation and implementation.

We will contact you again after that.

Thank you.

Following your instructions, I was able to resolve it with the following steps.

  1. The new plugin was not distributed with my project, so I got it from https://developer.nvidia.com/nvidia-texture-tools-exporter and installed
  2. Copied the NVIDIA Texture Tools for Adobe Photoshop directory from C:\Program Files\NVIDIA Corporation to C:\Program Files\Adobe\Adobe Photoshop 2023\Plug-ins\File Formats
  3. Deleted dds64.8bi installed inside C:\Program Files\Adobe\Adobe Photoshop 2023\Plug-ins

Now Help > About Plugins shows DDS-NVIDIA Texture Tools Exporter… instead of D3D/DDS…
In addition, I was able to confirm that reading and writing of DDS files was performed normally.

This issue has been resolved.
Thank you.

I am sorry. I said the problem was solved, but let me continue a bit further.

Since the latest plugin assumes the BC format, I would like to continue to use the old plugin in our current project that uses the DXT format.
Therefore, I have two questions.

  1. What version of PhotoShop will the old plug-in D3D/DDS (Version CS3 Release 1 (02/14/2007)) be unusable?
  2. Is it possible to fix the bug in the title now?

If it’s better to make it a separate topic, I’ll re-create it.

Best regards.

Hi osakmasa,

Thank you for the additional questions. The good news is that DXT1, DXT3, and DXT5 are the same as BC1, BC2, and BC3, respectively, in fact! If you were using DXT1, DXT3, or DXT5, the new plugin should be able to produce the same files - they’re just listed under the BC name introduced in DirectX 10.

Aside: There used to be DXT2 and DXT4 as well - those were BC1 and BC2, but the data was saved with premultiplied alpha. They’re not listed in the new plugin because there’s no DirectX 10 DXGI format for them, but there’s a Premultiply Alpha checkbox now that does much the same thing, and works with any format. For some reason, there was never a DXT6, which would have been premultiplied alpha BC3.

To answer questions 1 and 2, we don’t have plans to remove the legacy plug-in (that is, it will remain available to download), but we also don’t have plans to publish bug fixes for the legacy plug-in, since we have the new plug-in available.

Thanks again,

–Neil

Thanks for letting us know about the future of the old plugin.
I am very happy to hear that we can still use it! As for the bug, we plan to work around it in production. There doesn’t seem to be a rush to migrate environments for the current project.

However, as a reference when considering migration, is it possible to output DDS equivalent to the old L8A8 plugin with the latest plugin? If possible, I would appreciate if you could tell me what settings to use for output.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.