PhotoShop DDS GLEW Export error

Hi all,

I’ve just installed an RTX 7800XT GPU and since doing so I’m getting a GLEW error whenever I try to export a DDS from Photoshop using the v2023.3.2 of texture tools exporter.

  • I’ve got a (genuine) version of Photoshop CC 2024 installed, running in administrator mode
  • I’ve downloaded the standalone tool and this works fine
  • I’ve completely uninstalled and reinstalled the Photoshop plugin
  • Tried other basic things I can think of.

I saw a few similar topics but these seemed to suggest it was fixed in January this year, but I’m having the same issue with no idea of where to look next. Searching the error message gives very few results and most of them appear to be specific to software programming.

Any help would be greatly appreciated thanks.

Screenshot 2023-11-01 234026

Hi @rodgerdavies ! This is interesting, because it’s a different issue than the “Failed to initialize GLFW” bug! GLEW (which we use to load OpenGL extensions) is a different library than GLFW (which we use to create the window).

Could you clarify which GPU and driver you’re using? There’s no RTX 7800XT GPU I can find – did you mean the AMD RX 7800XT?



Sorry, my bad @nbickford - force of habit. Yes, it’s the AMD RX 7800XT. Driver is 23.10.2 released 16 Oct '23.

I’ve just tried with about 10 different files and consistently the same error, always the same line number 2816. Photoshop version is 25.1.0.

Thanks for the quick reply, much appreciated.

Interesting, I might have a go and see if I can test it out here on a similar GPU.

One other thing to check – does the standalone version work, by any chance? For the GLFW bug, we had an interesting situation where GLFW would fail to launch inside Photoshop, but work in the standalone version. I wonder if something similar here might be happening with GLEW.



Hi @nbickford - yep, the standalone version works fine for me, thanks. Bit of a faff but means work is still doable.

I will try to reinstall Photoshop at some point too, see if that makes any difference.

Let me know if you want any other specs.

To add some more information here @nbickford :

  • I uninstalled Photoshop and the plugin and then tried installing it again. Photoshop is installed and working fine, but when trying to install the plugin I’m getting the attached error message:

Screenshot 2023-11-04 220158

To fix the above, I ended up running it in Windows 8 compatibility mode, which gave me a successful install message. However, I’m still getting the same GLEW error on link 2816 as per the original message. I’ve tried running PS in the same compatibility mode, but no difference there.

Really appreciate your help as it’s becoming a time sink to not be able to use this, especially as Photoshop needs restarting each time I try.

The Intel version of this is working for me seemingly, so will have to use that one in the short-term.

Thanks @rodgerdavies ! For the installation error, if you see it again, it’s safe to delete that nvtt_export.8bi file (that’s the main plugin file); the installer should work without compatibility mode.

I’m going to try to repro this bug this week and see if I can determine what’s failing inside GLEW.



Hi, I have the exact same error as Roger, the standalone exporter works as expected, though it’s quite time consuming and double the steps to be able to save something as DDS now. Another thing I noticed is that the saved files don’t preview in my explorer anymore, which is very unhandy when it comes to quick color matching without opening the file.

This week I finally upgraded from a 960TI working fine with Photoshop 2021, to a 6800xt and Photoshop 2023

Edit: Was losing too much time saving double files to be able to convert it to DDS through the standalone, installed the Intel plugin instead which was advised in another similar thread here, which works fine for the work I need the plugin for.

I got the same error after my system was updated to W11 23H2.

Thank you all! I managed to reproduce the bug on a system using a Radeon™ VII and Adrenalin Edition™ driver 23.11.1 (November 3rd, 2023) on Windows 22H2.

On my test system, the plugin works with driver 23.8.2 (August 31st, 2023), so downgrading to that version might be a short-term fix until we release a new version of the plugin.

In case it helps anyone developing their own plugins who runs into this, it looks like the root cause is that the OpenGL version string provided to the Photoshop plugin is different between the two driver versions:

Driver version glGetString(GL_VERSION) from within the Photoshop plugin, on my test system
23.8.2 4.6.0 Compatibility Profile Context
23.11.1 1.0.0 Compatibility Profile Context

GLEW looks at this string, sees that it’s below version 1.1 on driver version 23.11.1, and refuses to initialize. This most likely happens because the plugin both runs inside Photoshop (where the OpenGL environment appears to be different) and uses the default OpenGL version GLFW provides (since specifying an explicit version causes issues with loading extensions on at least one other GPU driver). I have a workaround for this that will undergo additional testing before release.

There might also be a way to make the current driver report a newer OpenGL version by changing the settings the driver uses to run Photoshop in the official settings app, but I haven’t found a way to do this as of this writing.

Thanks again!