Odtk installation failure

I am trying to install odtk by following the page

GitHub - NVIDIA/retinanet-examples: Fast and accurate object detection with end-to-end GPU optimization

but fails with the command

docker build -t odtk:latest retinanet-examples/

=> ERROR [3/3] RUN pip install --no-cache-dir -e odtk/                                                                                                                    16.5s
------                                                                                                                                                                           
 > [3/3] RUN pip install --no-cache-dir -e odtk/:                                                                                                                                
#0 0.702 Obtaining file:///workspace/odtk                                                                                                                                        
#0 2.167 Collecting apex@ git+https://github.com/NVIDIA/apex                                                                                                                     
#0 2.167   Cloning https://github.com/NVIDIA/apex to /tmp/pip-install-qn0lrhnk/apex_6224902375124fccab9fbdea99934b2d                                                             
#0 2.167   Running command git clone -q https://github.com/NVIDIA/apex /tmp/pip-install-qn0lrhnk/apex_6224902375124fccab9fbdea99934b2d                                           
#0 3.956   Resolved https://github.com/NVIDIA/apex to commit 9fc94b7d6db1b178adf9a6e92750f070dd9f825d
#0 3.956   Running command git submodule update --init --recursive -q
#0 9.772   Installing build dependencies: started
#0 13.72   Installing build dependencies: finished with status 'done'
#0 13.73   Getting requirements to build wheel: started
#0 13.89   Getting requirements to build wheel: finished with status 'error'
#0 13.89   ERROR: Command errored out with exit status 1:
#0 13.89    command: /opt/conda/bin/python3.8 /opt/conda/lib/python3.8/site-packages/pip/_vendor/pep517/in_process/_in_process.py get_requires_for_build_wheel /tmp/tmpd1_81dbz
#0 13.89        cwd: /tmp/pip-install-qn0lrhnk/apex_6224902375124fccab9fbdea99934b2d
#0 13.89   Complete output (15 lines):
#0 13.89   Traceback (most recent call last):
#0 13.89     File "/opt/conda/lib/python3.8/site-packages/pip/_vendor/pep517/in_process/_in_process.py", line 349, in <module>
#0 13.89       main()
#0 13.89     File "/opt/conda/lib/python3.8/site-packages/pip/_vendor/pep517/in_process/_in_process.py", line 331, in main
#0 13.89       json_out['return_val'] = hook(**hook_input['kwargs'])
#0 13.89     File "/opt/conda/lib/python3.8/site-packages/pip/_vendor/pep517/in_process/_in_process.py", line 117, in get_requires_for_build_wheel
#0 13.89       return hook(config_settings)
#0 13.89     File "/tmp/pip-build-env-0uc8vn5f/overlay/lib/python3.8/site-packages/setuptools/build_meta.py", line 355, in get_requires_for_build_wheel
#0 13.89       return self._get_build_requires(config_settings, requirements=['wheel'])
#0 13.89     File "/tmp/pip-build-env-0uc8vn5f/overlay/lib/python3.8/site-packages/setuptools/build_meta.py", line 325, in _get_build_requires
#0 13.89       self.run_setup()
#0 13.89     File "/tmp/pip-build-env-0uc8vn5f/overlay/lib/python3.8/site-packages/setuptools/build_meta.py", line 341, in run_setup
#0 13.89       exec(code, locals())
#0 13.89     File "<string>", line 5, in <module>
#0 13.89   ModuleNotFoundError: No module named 'packaging'
#0 13.89   ----------------------------------------
#0 13.89 WARNING: Discarding git+https://github.com/NVIDIA/apex. Command errored out with exit status 1: /opt/conda/bin/python3.8 /opt/conda/lib/python3.8/site-packages/pip/_vendor/pep517/in_process/_in_process.py get_requires_for_build_wheel /tmp/tmpd1_81dbz Check the logs for full command output.
#0 13.90 Collecting pycocotools@ git+https://github.com/nvidia/cocoapi.git#subdirectory=PythonAPI
#0 13.90   Cloning https://github.com/nvidia/cocoapi.git to /tmp/pip-install-qn0lrhnk/pycocotools_096a3f20eb67469ab8244ed82c33af1f
#0 13.90   Running command git clone -q https://github.com/nvidia/cocoapi.git /tmp/pip-install-qn0lrhnk/pycocotools_096a3f20eb67469ab8244ed82c33af1f
#0 15.34   Resolved https://github.com/nvidia/cocoapi.git to commit fa44301f7a8b3f95a9f2751d19bfd735b0f6c65d
#0 15.82 Requirement already satisfied: torch>=1.0.0a0 in /opt/conda/lib/python3.8/site-packages (from odtk==0.2.6) (1.10.0a0+3fd9dcf)
#0 15.82 Requirement already satisfied: torchvision in /opt/conda/lib/python3.8/site-packages (from odtk==0.2.6) (0.11.0a0)
#0 15.93 ERROR: Could not find a version that satisfies the requirement apex (unavailable) (from odtk) (from versions: 0.9.8dev.linux-i686, 0.9.8.dev0, 0.9.8a0.dev0, 0.9.9.dev0, 0.9.10.dev0)
#0 15.93 ERROR: No matching distribution found for apex (unavailable)
------

I tried 3 different Ubuntu computers, but the results are the same. Also tried to install apex manually but no luck. Any solution?

same problem here,