OFED 5.8 on RHEL/Rocky 8.8

Hello, I am trying to install OFED (looking at latest 5.8- on Rocky 8.8 but even with --skip-distro-check I get an error that the operating system is not supported. Is there a path-more-travelled way to install this?

The OFED just can’t support Rocky 8.8 directly.
we can try to use ‘–add-kernel-support’ , ex:
#./mlnxofedinstall --force --skip-distro-check --distro rhel8.8 --add-kernel-support --skip-repo

after installation , execute:
#dracut -f

more infomation refer to:


I tried this command on Rocky 8.8, but still got some errors when building the RPM packages.

I ran ./mlnxofedinstall --force --skip-distro-check --distro rhel8.8 --add-kernel-support --skip-repo and got:

/tmp/MLNX_OFED_LINUX-4.9- In function 'mlx4_en_activate_cq':
/tmp/MLNX_OFED_LINUX-4.9- error: macro "netif_napi_add" passed 4 arguments, but takes just 3
/tmp/MLNX_OFED_LINUX-4.9- error: 'netif_napi_add' undeclared (first use in this function); did you mean 'netif_napi_del'?
   netif_napi_add(cq->dev, &cq->napi,
/tmp/MLNX_OFED_LINUX-4.9- note: each undeclared identifier is reported only once for each function it appears in
/tmp/MLNX_OFED_LINUX-4.9- error: macro "netif_napi_add" passed 4 arguments, but takes just 3
   netif_napi_add(cq->dev, &cq->napi, mlx4_en_poll_rx_cq, 64);
make[3]: *** [scripts/Makefile.build:317: /tmp/MLNX_OFED_LINUX-4.9-] Error 1

Maybe the driver does not support the kernel version of Rocky 8.8 (4.18.0-477.10.1.el8_8.x86_64)?

OFED 4.9 maybe too old to support Rockey OS. Could you try OFED 5.8

Hi, so I tried

./MLNX_OFED_LINUX-5.8- --force --skip-distro-check --distro rhel8.8 --add-kernel-support --skip-repo

but it gave me

/lib/modules/4.18.0-477.10.1.el8_8.x86_64/build/scripts is required to build mlnx-ofa_kernel RPM.
Please install the corresponding kernel-devel RPM.

Error: One or more required packages for installing OFED-internal are missing.

yum install kernel-devel-4.18.0-477.10.1.el8_8.x86_64
Failed to build MLNX_OFED_LINUX for 4.18.0-477.10.1.el8_8.x86_64

But this package is already installed…

yum install kernel-devel-4.18.0-477.10.1.el8_8.x86_64
Last metadata expiration check: 23:36:43 ago on Tue 06 Jun 2023 04:47:44 PM -03.
Package kernel-devel-4.18.0-477.10.1.el8_8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

Did I miss anything?