OFED install failing for RHEL 8.8 (MLNX_OFED_LINUX-5.8-

So I am attempting to install MLNX_OFED_LINUX-5.8- drivers onto my RHEL 8.8 machine.
Kernel Version: 4.18.0-477.21.1.el8_8.x86_64

I first tried. ./mlnxofedinstall
which failed.
then tried ./mlnxofedinstall --add-kernel-support --force --skip-repo --distro rhel8.8
That also failed with these results
“Failed to build OFED-Scripts 5.8RPM”
“Unpacking of archive OFED-Scripts cpio:Digest Mismatch”
“OFED-Scripts src.rpm cannot be installed”

I get the same results as above when I try to run ./mlnx_add_kernel_support.sh --t /tmp/mlnx_ofed_build --make-tgz --mlnx_ofed /tmp/MLNX_OFED

/tmp/MLNX_OFED/ contains the untarred driver directory.

Any help would be greatly appreciated. Not sure if I am doing something incorrectly or if I have a wrong kernel version. The documentation is 404’d for 5.8- I was following this guide for a reference as well. https://www.rdmamojo.com/2014/11/30/working-rdma-using-ofed/


Hello @colter.sisler,

Thank you for posting your query on our community. The default kernel for RHEL 8.8 is 4.18.0-477.10.1.el8_8.x8
6_64. Since you are using a different kernel version, I would suggest using the below command to install the drivers:
$ ./mlnxofedinstall --add-kernel-support

MLNX_OFED 5.8- LTS drivers for RHEL 8.8 can be downloaded from this link - Linux InfiniBand Drivers


@sribhargavid Thanks for the reply! From my OP I did try that add-kernel-support and still received the same error. I get that error for ./mlnx_add_kernel_support.sh

Should I downgrade the kernel instead?