Omniverse Kit Remote Client SDL Error

I am running an Issac Sim Headless container on a gcp instance of Ubuntu 18.04. Here are the GPU specs:

I am running the headless container using the following command:

sudo docker run --entrypoint ./runheadless.websocket.sh --gpus '"device:0"' -e "ACCEPT_EULA=Y" --rm --network=host nvcr.io/nvidia/isaac-sim:2021.1.1

I am trying to livestream the isaac environment using Omniverse Kit Remote Client on the local instance using

./kit-remote.sh -s 127.0.0.1

but I am unable to initialize SDLGraphicContext. I installed all the necessary packages to install the streaming client. Here is the error message I get when I run the remote kit.

I am not sure if I am missing any dependency or if it is not compatible with the hardware.

Hi, to run Isaac Sim with Kit Remote, use this command:

sudo docker run --entrypoint ./runheadless.kitremote.sh --gpus ‘“device:0”’ -e “ACCEPT_EULA=Y” --rm --network=host nvcr.io/nvidia/isaac-sim:2021.1.1

Is the client on Ubuntu 18.04?
Please run the following commands to check if you GL drivers is working.
This should show “Yes”

glxinfo | grep “direct rendering”

This should open a windows with rendered moving gears:

glxgears

Thanks for the reply. I ran the ./runheadless.kitremote.sh but I still got the same error when I run ./kit-remote.sh locally.

Output of glxinfo | grep "direct rendering"
Screen Shot 2021-07-30 at 8.02.41 AM
but the direct rendering is enabled as can be seen by running glxinfo | grep render


I am also able to see the rendered gears moving and yes the instance is running on Ubuntu 18.04.

This is odd. May I know what GPU is on the machine running Kit Remote Client and is a display connected to it?
Does the WebSocket mode works for you using the browser?

Both the kit remote client and the docker are running on the same A100 Google Cloud Instance. I am using nomachine client on a mac to display a Ubuntu 18.04 GCP instance. I am also unable to use the Websocket for browser it says to play video you may need to install the required video codecs.

Do you get this error on the Mac? Try running the url on a Chrome browser.

The browser was also opened in the same Ubuntu instance but in Firefox.

Try using Chrome on the instance as well as on the Mac if possible.
We have tested it on Chrome for Mac.

1 Like

I tried running streaming on a chrome browser. I get the below messages on the terminal after pressing the play button and the browser just displays a black screen.

Does that happen all the time?
Try waiting for this to show in the log before clicking the Play button:

Isaac Sim Headless Websocket App is loaded.

Yes, it happens all the time. I always wait until I see

Isaac Sim Headless Websocket App is loaded.

Also should we run it with a Nucleus workstation or should it load up the display without a remote Nucleus workstation.

You will need access to a local or remote Nucleus to run the samples but it should not crash when running without one.
There might be an issue with NVENC. Try reinstall the drivers or try the 460.91.03 drivers.

1 Like

Sorry, I just realized you are running on A100s which do not support NVENC. Can you try running on an instance with T4 GPU instead?

1 Like

Thanks for the help. I am currently using T4 and I am able to run both the kit remote and the websocket containers. But there is a significant latency in the application.

However I am still unable to launch it from the Omniverse-launcher. The launch button next to Isaac SIM doesn’t respond. When I try running it from the terminal using

/home/ravi/.local/share/ov/pkg/isaac_sim-2021.1.1/isaac-sim.sh -v

it exits with following error

I would prefer to run it using the omniverse launcher over the docker container. Any suggestion on what I might be missing?

Windowed Isaac Sim may not work over VNC or nomachine because it is a Vulkan application. It is possible to get it working if the remote host has a display attached but without a physical display, a workaround is non-trivial.

1 Like

Thanks that makes sense.

1 Like