Isaac Sim (and Isaac Gym) installation on a remote workstation

Hello,
I am trying to install Isaac Sim on a remote workstation accessing through Microsoft Remote Desktop. Unluckily, my multiple attempts to install the simulator resulted in a failure.

Hardware and driver requirements (I also installed Vulkan SDK and Isaac SDK) are all respected. I tried mainly two ways for installing Isaac Sim:

  1. I tried to install using the Omniverse app: after that I install it I try to launch it clicking on “launch” but nothing happens. I really can’t figure it out, I read on some previous topics that Isaac Sim App rendering is not possible remotely (no livestream mode). Is it correct?

  2. I tried to install it using as an headless container (using ssh). Using all three protocols it always returns "Aborted (core dumped)"and the installation cannot be completed.

Could you please help me in figuring this out in order to complete my installation of Isaac Sim?

I also installed Isaac Gym but when I try to run it, it loads the example but immediately returns a segmentation fault error. I followed the documentation guide step-by-step thus I start thinking that probably there’s a problem with my workstation or using the remote control.
IsaacSim.zip (78.0 KB)

I attach the logs related to all Isaac Sim installation method and nvidia-sim.

Thank you.
Jacopo

Hi. Yes, an Omniverse app may not work using a remote desktop (especially if the host does not have a connected display) because it is rendered using Vulkan.
Your drivers and GPU looks ok. For running on the Mac, the Websocket mode is recommended with Chrome or Safari.

I’ve found this error in the logs:
HTTPServer failed to start: [Errno 98] Address already in use
Try doing a reboot on your Linux machine and make sure the ports 8899 and 8211 are not in use.
The Websocket client will be ready to connect when you see this line in the logs.
Isaac Sim Headless Websocket App is loaded.

Hello Sheikh,
Thanks fo your reply. For what concerns the rendering problem, I think it is the same even using Isaac Gym. Is it correct? In fact, when I removed the viewer part from the example code, it started properly working.

About the installation in container mode, I did as you suggested and after several attempts it worked. Now I can access using WebSocket protocol, but only using this one because the other two still return error. Anyway, when I try to access Isaac Sim interface from the browser it is really slow (it is so slow that it is impossible to be used). Do you know a way to optimise it?

Thank you very much
J

Yes, I believe it is the same.

I’m afraid there are still issues in some cases when using Kit Remote. Websocket should work most of the time but maybe not be as fast as the Kit Remote. We are continually improving the live-streaming feature for the next version.