WebRTC and Websocket stream not connecting

I am trying to use the streaming services for Isaac Sim, as to access my workstation remotely and if possible have more than one instance running and connected at once, and to do this I would like to use Websocket or WebRTC. Unfortunately, I cannot seem to make either work, as in both cases the headless instance starts and seems to work fine, but I cannot connect neither remotely nor locally.
In the Websocket case I can connect, but the only thing that appears is this JSON related page

which appears both remotely and locally (I have tried Firefox, Chrome and Opera as for browsers).
For the WebRTC case, instead, I always get redirected to; locally, I get the red button page shown below as I would expect, but it does nothing after pressing on it, while remotely it just refuses connection as I think the IP address it get redirected to is the laptop’s localhost, which does not have any WebRTC server running.

Is there something I am doing wrong? Or could there be something wrong with my installation? How can I solve this issue? If it can be of any help here are the logs.

Websocket kit_20231121_095509.log (1.2 MB)
WebRTC kit_20231121_102308.log (5.3 MB)

Hi. Are both your workstation and laptop on the same local network?
Try using Chrome on your laptop and open http://<workstation_ip_adress>:8211/streaming/webrtc-demo/?server=<workstation_ip_adress>

On your workstation, you can use these urls:


Thank you for the answer. Yes, my laptop and workstation are on the same local network, as I can connect through the native Streaming Client and use Isaac Sim just fine. Using the new link you provided me i can at least reach the WebRTC red button page from the laptop and click on it, but there still lies the problem: I cannot see anything on screen except a grey rectangle and the stop button below it, and the same applies locally on the workstation.
As for the Websocket, do you have any insight on how I could make that work? I am interested in that streaming solution, too, as I’ve read here (How can I run multiple isaac-sim container in one machine and connect them with browser) it is possible to change its default ports, which would be extremely useful in my case.

Here’s the main guide for WebRTC.

Can you also try the WebRTC extension on USD Composer or Kit to see if you can reproduce the same issue?

Thank you for the documentation link. I have not been able to start the WebRTC stream using Kit, as by following the documentation I am not able to find the omni.services.streamclient.webrtc extension, but I was able to do so on the USD Composer app. However, the issue is still the same, I can see the initial page but clicking play leads to the same still screen. Do you have any insight as to why this may happen?

At this point I am also unsure if this is the correct way to reach my goal, which would be having multiple headless instances of Isaac Sim running at once on my workstation and then controlling them from remote machines.