On Jetson XAVIER-NX board, how to set tegra-rtc(RTC1) as default RTC

seems there are two RTC on Jetson xavier -nx. ls -l /dev/rtc*:

/dev/rtc -> rtc1

system log show that RTC0 was max77620-rtc and RTC1 was tegra-rtc,

I connect a coin battery on Jetson xavier - NX for RTC1, after set system time and disable timesyncd service. use hwclock -w -f /dev/rtc1, the system time can sync to RTC. but if I use hwclock -w without -f options, it seems hwclock did’t work.

I want to use tegra-rtc as default RTC by disable max77620-rtc by remove node like 'RTC0 ', but I didn’t found any node that named “max77686-rtc” or “max77620-rtc”,what should I do to.

BWT, if had disabled RTC0 or remove RTC0 from device tree, can I use hwclock without -f options to set RTC time ?.

please check Topic 125927, and Topic 183601 as see-also.