OpenCV Linker Errors

I am trying to include a few different OpenCV libraries for a project I am working on. When I go to compile my OpenCV program, I receive this error:

../demo.cu:17:10: fatal error: 'opencv2/opencv.hpp' file not found

My source code is the following:

#include <opencv2/opencv.hpp>
#include <opencv2/core.hpp>
#include <opencv2/imgproc.hpp>
#include <opencv2/cudaimgproc.hpp>
#include <opencv2/videoio.hpp>
#include <opencv2/highgui.hpp>
#include <opencv2/cudaimgproc.hpp>
#include <opencv2/imgcodecs.hpp>
#include <opencv2/cudacodec.hpp>

My settings are the following:
Project Properties -> Build -> Settings -> Tool Settings ->NVCC Compiler -> Includes:

"usr/include"
"usr/local/cuda/include"

Project Properties -> Build -> Settings -> Tool Settings ->NVCC Linker -> Libraries (-l):

opencv_core
opencv_videoio
etc...
.
.

Project Properties -> Build -> Settings -> Tool Settings ->NVCC Linker -> Library Search Path (-L):

"usr/lib"

I have verified that all of my libraries and files are in these folders and still receive the compiler error. I am not sure what is wrong any help is appreciated

I noticed my mistake soon after posting. I was trying to debug the code locally and not remotely. However, I receive a new error when trying to compile the code.

/usr/local/cuda-6.5/bin/nvcc: not found
subdir.mk:18: recipe for target 'demo.o' failed
make: *** [demo.o] Error 127

When I go to “/usr/local/cuda-6.5/bin/” I only see “gcc” and “g++”
What is the fix for this? I have not touched the cuda toolkit in a long time and have not seen this error before

*Edit - I checked some other forums to figure out what was going on and I guess my cuda toolkit somehow vanished?

whereis nvcc

return

nvcc:

I can’t install the DEB cuda toolkit 6.5 because I get the following error (I am running Ubuntu 16.04):

http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/armhf/Release.gpg: Signature by key 889BEE522DA690103C4B085ED88C3D385C37D3BE uses weak digest algorithm (SHA1)
E: Failed to fetch http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/armhf/Release  No Hash entry in Release file /var/lib/apt/lists/partial/developer.download.nvidia.com_compute_cuda_repos_ubuntu1404_armhf_Release which is considered strong enough for security purposes
E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried installing with a RUN installation and that worked well but my system is an ARMv7 32 bit and the RUN installations are only for 64 bit so that also did not work.

What do I do? I need the nvcc compiler on my system so I can work on my code