OpenGL Compile Issues w/ Cuda V1.1

Guys - I am a new user and I apologize in advance if this is a trivial question…

My setup is as follows: Dell XPS 410, Intel Duo Core, Win XP 32, VS2005 Express, GeForce 8600GTS (also used for primary display device).

I have recently upgraded to the newly released V1.1 Toolkit, SDK and V169 Forceware driver. I can now NOT compile any of the examples in the SDK which use open GL, or contain the following header:

#ifdef _WIN32


include <windows.h>

#include <cuda_gl_interop.h>
#include <cutil.h>

Depending on the project, I get a multitude of ‘file not found’ errors pertaining to windows.h, win.h, GL/gl.h, etc… All other SDK example appear to work fine.

A typical error message looks like the following:

1>------ Build started: Project: postProcessGL, Configuration: Release Win32 ------
1>Performing Custom Build Step
1>C:\CUDA\include\cuda_gl_interop.h(46) : fatal error C1083: Cannot open include file: ‘GL/gl.h’: No such file or directory


1>------ Build started: Project: fluidsGL, Configuration: Release Win32 ------
1>Performing Custom Build Step
1>c:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc\GL/glew.h(1123) : fatal error C1083: Cannot open include file: ‘GL/glu.h’: No such file or directory

Based on other posts, I uninstalled the Driver, Tookit and SDK and reinstalled them exactly in that order… Same result…

I suspect that for some reason that I don’t have an include path set correctly, or all of the required project files are not being installed to the correct location. Funny thing is that the only copies of windows.h and win.h I had on my hard drive were in a Matlab 2007b include directory. Some of the GL files, such as GL/glu.h (as required by the fluidsGL program) are NOT on my hard drive at all!

I was able to run all of the examples in the V1.0 SDK just fine, and I never needed to modify a path, or add a file…

I definitely appreciate any insight anyone might have.


why not copy openGL’s lib and h’s from openGL website to your working directory?

Hi - I’ve been browsing thru the openGL website, and I am confused as to what exactly I would need to download and install. Again, I’m not sure why all the openGL SDK examples would work under V1.0 and not under V1.1 with the 169 driver??? Surely there is not a bug in the install program, as I would expect everyone else would have this problem too.

If you could point me in the right direction, I’d appreciate it… Thanks…

Using Visual Studio 2005 and when I follow from and browse to glut.h I see it’s finding glu.h here:
C:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\Include\gl

Using 2005 Express Edition, I find it here:
C:\Program Files\Microsoft Visual Studio 8\VC\include\gl

When I use the express edition, I also install the microsoft platform sdk. You may need that to get these files. I typically install it right into the VC directory.

dhoff - Ah, I think that may be it. When I had this working with CUDA V1.0, I was using VS Express 2008 and I had also installed the 2008 Platform SDK which was on the install DVD (this was before I realized that 2008 wasn’t supported, which was odd because everything WORKED just fine, I think I ran almost every CUDA SDK example).

Anyway, when I uninstalled V1.0 and installed 1.1, I ran into problems, and then realized from reading posts on the board that VS 2008 was the problem. I then uninstalled 2008 and installed 2005 - but I didn’t have the platform 2005 SDK.

This is my home PC, and I don’t have broadband - so I must retrive the platform SDK at work and try this on my home machine tomorrow night.

I appreciate your insight, and I’ll post the results after I try it tomorrow. I would be surprised if other users didn’t run into this.

Thanks again,