Orbitty Carrier and Jetpack 3.1

I’m about to order and begin testing of a portable object localization system using the Orbitty carrier board.

For those of us who need all the performance we can get and want to use Jetpack 3.1, where do we stand with its compatibility with the Orbitty? The posts I’m seeing state the Orbitty only works with 3.0. Is this still the case?

And do I still need to stand up an ubuntu 14.04 image just to install Orbitty software, or has that been updated as well?

Hi dbrownrxvs0, ConnectTech Orbitty currently has L4T BSP support for TX1/TX2 available through JetPack 3.1 / L4T R28.1.
Obtain the Orbitty BSP from their Downloads tab here and see the Release Notes. Contact ConnectTech Support if you have issues.

As with the Jetson TX1/TX2 Developer Kit, an x86_64 host PC is required with Ubuntu 14.04 (or Ubuntu 16.04 can work if you disable host-side packages for OpenCV4Tegra and VisionWorks). This is standard for running JetPack-L4T to flash the Jetson (although some have gotten a VM to work).

Got my Orbitty and am looking forward to setting it up later. It looks like I have to re-flash it and start over from scratch to install the BSP, and can’t do it with an existing installation that used the provided nvidia carrier board, correct?

Here is a better direct link to download the L4T r28.1.0 package, and here are the installation steps:

  1. Before Installing the CTI BSP you will need to go through the full initial Jetpack 3.1 installation on an x86 host system running Ubuntu 14.04 and a minimal of 32GB of free storage space.

  2. Once the above is completed, then copy the CTI-L4T-V###.tgz package into <install_dir>/64_TX2/Linux_for_Tegra/ in the host machine:

  3. Extract the BSP:

    tar -xzf CTI-L4T-V###.tgz

    ([i]replacing ### with the numbers in the file name[/i])
    
  4. Change into the CTI-L4T directory.

  5. Run the install script (as root or sudo) to automatically install the BSP files to the correct locations:

    sudo ./install.sh

==================================================================================
The CTI-L4T BSP is now installed on the host system and it should be able to flash the TX2.

  1. Connect the TX2 and Orbitty Carrier to the computer via the micro USB

  2. Put the system to be flashed into recovery mode, following the instructions in the manual

  3. To flash on the tx2, run ./flash.sh orbitty mmcblk0p1 from the Linux_for_Tegra directory

NOTE: Once the flashing has completed, the TX2 will reboot.

==================================================================================
Notice that the installation of the CTI BSP will overwrite files on the TX2 previously installed by the Jetpack automatic installer. Therefore, post-installing the CTI BSP, you will need to follow these steps to re-install Cuda and other Jetpack packages on the TX2 without re-flashing the entire TX2.

  1. Connect the target TX2 system to the same network as your host machine and determine its IP address.

  2. Re-launch the Jetpack installer and select the TX2:

./JetPack-L4T-X.X-linux-x64.run

  1. Change all entries other than “Install on Target” from “install” to “no action” in the GUI.

The Jetpack will download any missing packages that are required; which may take some time.

  1. Enter the IP address of your TX2 system, as well as the username and password (nvidia and nvidia)

The Jetpack will then install and configure your various packages over the network the same way it does when running the default configuration, but it will leave the CTI L4T BSP files installed.

Orbitty carrier referefence

I’m using a Jetson TX2 in my laboratory with a ConnectTech Orbitty career board. I flashed it with ConnectTech’s BSP L4T 28.2 kernel version 4.4.38-tegra and then installed the necessary packages with Jetpack 3.2.1.

I am trying to interface this to an Arduino based board: TREX controller. Here is the description of my problems and the steps I have taken:

  1. When uploading a sketch from arduino IDE (on TX2), upload fails with following error:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

Also arduino board and the TREX board are recognized as ttyS0, instead of ttyACM or ttyUSB.

  1. To solve this, I tried to install the CP2102N USB drivers from https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers.

When I run the make command in the folder of the driver, I get this error:

make -C /lib/modules/`uname -r`/build M=/home/nvidia/Downloads/Linux_3.x.x_4.x.x_VCP_Driver_Source modules
make[1]: Entering directory '/usr/src/linux-headers-4.4.38-tegra'
  CC [M]  /home/nvidia/Downloads/Linux_3.x.x_4.x.x_VCP_Driver_Source/cp210x.o
<b>scripts/basic/fixdep: 1: scripts/basic/fixdep: Syntax error: "(" unexpected</b>
scripts/Makefile.build:267: recipe for target '/home/nvidia/Downloads/Linux_3.x.x_4.x.x_VCP_Driver_Source/cp210x.o' failed
make[2]: *** [/home/nvidia/Downloads/Linux_3.x.x_4.x.x_VCP_Driver_Source/cp210x.o] Error 2
Makefile:1414: recipe for target '_module_/home/nvidia/Downloads/Linux_3.x.x_4.x.x_VCP_Driver_Source' failed
make[1]: *** [_module_/home/nvidia/Downloads/Linux_3.x.x_4.x.x_VCP_Driver_Source] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.4.38-tegra'
Makefile:7: recipe for target 'all' failed
make: *** [all] Error 2

Although this looks like a syntax error, the following sources say that its due to some errors in kernel headers.

https://www.incentivespro.com/forum/viewtopic.php?t=214
https://github.com/thoughtpolice/enable_arm_pmu/issues/4

  1. According to their suggestion, I tried the following command:
cd /usr/src/linux-headers-4.4.38-tegra
sudo make modules_prepare

which fails with the error:

grep: scripts/../arch/x86/entry/syscalls/syscall_32.tbl: No such file or directory
  1. When I searched about that error, I found from NVIDIA forums that it occurs only if I try to cross compile from an x86 system. But I’m doing all this on the TX2 board itself.

https://devtalk.nvidia.com/default/topic/1027484/jetson-tx2/trying-to-build-a-module-with-no-luck/


I have another TX2 in the lab which is fitted with a larger (different) development board. I have no problem communicating with arduino from that.

Therefore, all I want is to communicate with my arduino. I have spent about 10 days trying to figure this out. Kernel modification is beyond my linux experience, but I now believe this is a problem due to the customized kernel released by ConnectTech for their Orbitty career board.

I would appreciate any kind help regarding any step of this problem. Thanks

Please, just one post, it’s confusing to see multiple posts on old topics. Answered here:
https://devtalk.nvidia.com/default/topic/1038629/jetson-tx2/unable-to-install-cp210x-drivers-for-usb-serial-communication-on-tx2-with-orbitty/