Orin flashed to external USB drive. But doesn't boot from it

System I have is an Orin NX (16GB). I flashed the system to an external USB drive (128GB). The flashing process was quite smooth, using the following command

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device sda1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 p3509-a02+p3767-0000 internal

Afterwards, the system booted from the external USB. Then I went through all the GUIs on the license agreement, setting up applications, setting up Chrome, etc. See for example,

System rebooted after setting up. But, it ignored the USB drive and tried to boot from internet without success. Eventually, it ended up in an UEFI shell. See the photos.

How do I fix it? Suggestions and comments are highly appreciated.


have you checked if you are able to enter the UEFI boot menu to change the boot order?
Or try removing the Ethernet cable in case it’s plugged in to the device.

Thank you for your reply. The Ethernet cable was not connected. Yes, I entered the UEFI boot menu, but the external USB was not on the list, only UEFI HTTP, UEFI PXE and UEFI Shell entries.

Then does re-flashing work?

No. Same “symptom”. After the setting GUIs, failed to boot from USB drive.

Can you attach the booting log from serial console here?

How do I get the booting log as it doesn’t boot.

See what you can get with this:


couple more question here.
Is the carrier board a custom one, or the Xavier NX DevKit(p3509-a02+p3767-0000)?
What L4T version is in use? Have you tried with a different USB drive?

  1. Carrier board is a devkit (p3509-a02+p3767-0000).
  2. Jetson Linux R35.3.1
  3. Success in using the following command to flash an internal nvme (connected via M.2)
sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" 
  --showlogs --network usb0 p3509-a02+p3767-0000 internal

So it only happens with the USB drive, but not the NVMe drive?
Does upgrading to 35.4.1 make any difference?
How about the UART log?

Upgrading to 35.4.1 didn’t make any difference. I cannot access the UART log.

So is everything working fine on an NVMe SSD after the system configuration?
While a USB drive fails to boot up after that?

How about this?

What did you mean?
You mean it didn’t output anything, or you don’t have a TTL-USB cable?
It’s hard to further debug without UART log.

Flashing to the NVME was successful and the OS boots normally. However, flashing to an external USB results in failure as I mentioned in the first post. Different USB driver yields the same result, no boot. I don’t have access to UART, neither can I connect to with TTL-USB.

Then there’s little we can do here, and if NVMe drive works fine, just take it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.