Orin hdmi

We debug HDMI on our own customized board. Before the device is powered on, HDMI can be normally connected, and there is no problem with continuous plug and pull; However, after the device is powered on and started for a period of time, the HDMI cannot be displayed normally after being inserted. Is there any such problem?

Hi @lpz_thread. I’ve moved your question over to the right forum.

Sorry for the late response, is this still an issue to support? Thanks

I have the same problem.

yes ,if we connect hdmi before board power up,after the systerm running ,we Plug in and remove the hdmi port,it display normally;but after the systerm running,we plug the hdmi ,it could not display ;it seems “the os_gpio_hotplug” have no effect

Can this issue be reproduced o Orin devkit?
SW is JetPack 5.1 GA release, right?

Orin devkit is DP ,not HDMI ,We test the Orin devkit DP interface,only have appeared once could not display;Out Sw is Jetson Linux 35.1 GA release

What is your device tree change to enable HDMI on this custom board?

display@13800000 {
status = “okay”;
os_gpio_hotplug_a = <&tegra_main_gpio TEGRA234_MAIN_GPIO(M, 0) GPIO_ACTIVE_HIGH>;
};
add the os_gpio_hotplug_a and modify the nvidia,dcb-image with the patch

Hi,

I read your comment again. But I don’t really understand what is the exact scenario to hit issue.

For example, what does that mean “before the device is powered on”? What is “device” here? Jetson or moniotr?


坦白說你一開始的comment裡面有些英文的用詞這裡好像不是太精確. 我不是很確定你到底是哪個狀況下會打到問題.

这里的设备指的是Orin jetson,我的意思是设备启动前插入HDMI,等待系统完全启动后,多次拔插HDMI接口都正常,但是在系统启动后再插入HDMI接口的话,HDMI不能正常显示

ok, so it is hotplug issue.
Could you clarify if you ran a full flash after those device tree update?


所以你是指熱插拔部份有問題. 可以請問一下在你改了那些device tree change之後你有做full flash嗎?

yes ,I run a full flash

Could we review what patches you added?


我們可以看一下你總共加了哪些patch嗎?

1、used the hdmi dcb file for ga5.0.2
-#include “tegra234-dcb-p3701-0000-a02-p3737-0000-a01.dtsi”
+#include “tegra234-dcb-p3701-0000-a02-p3737-0000-a01-hdmi-4-ga5.0.2.dtsi”
2、add os_gpio_hotplug_a
display@13800000 {
status = “okay”;

  •   os_gpio_hotplug_a = <&tegra_main_gpio TEGRA234_MAIN_GPIO(M, 0) GPIO_ACTIVE_HIGH>;
    

    };
    3、modify bootloader/t186ref/BCT/tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi
    @@ -362,7 +362,7 @@

      	dp_aux_ch0_hpd_pm0 {
      		nvidia,pins = "dp_aux_ch0_hpd_pm0";
    
  •   		nvidia,function = "dp";
    
  •   		nvidia,function = "rsvd1";
      		nvidia,pull = <TEGRA_PIN_PULL_NONE>;
      		nvidia,tristate = <TEGRA_PIN_ENABLE>;
      		nvidia,enable-input = <TEGRA_PIN_ENABLE>;
    

diff --git a/bootloader/tegra234-mb1-bct-gpio-p3701-0000-a04.dtsi b/bootloader/tegra234-mb1-bct-gpio-p3701-0000-a04.dtsi
index 8afec26…307cfba 100644
— a/bootloader/tegra234-mb1-bct-gpio-p3701-0000-a04.dtsi
+++ b/bootloader/tegra234-mb1-bct-gpio-p3701-0000-a04.dtsi
@@ -39,6 +39,7 @@
TEGRA234_MAIN_GPIO(Q, 6)
TEGRA234_MAIN_GPIO(Q, 7)
TEGRA234_MAIN_GPIO(R, 1)

  •   		TEGRA234_MAIN_GPIO(M, 0)
      		TEGRA234_MAIN_GPIO(N, 4)
      		TEGRA234_MAIN_GPIO(N, 1)
      		TEGRA234_MAIN_GPIO(G, 0)
    

Are you sure this pinmux file are getting flashed to your board? JP5.0.2 has some known issue in confirming which board you are using.

Also, where is your dcb image?

yes,because we modify other function also will modify the pinmux file,and it worked;so we sure the pinmux file are getting flashed。the dcb image from tegra234-dcb-p3701-0000-a02-p3737-0000-a01-hdmi-4-ga5.0.2.dts

Could you check /sys/kernel/debug/gpio and see if M,0 is assigned with hotplug function?

Also, hotplug your HDMI cable and see if it gets response.

And are you sure your device tree is also getting flashed? The reason to highlight “full flash” is because the dtb is not used by kernel. But by DCE firmware and that requires full flash to take effect.

I’m also confused that this pin is not assigned through /sys/kernel/debug/gpio,but i sure os_gpio_hotplug_a is add;Also, hotplug your HDMI cable could not get response from kernel dmesg or /proc/interrupt

our module is 32GB Orin