Orin NX MASS FLASH Failing for Custom Carrier Board

Hi
I tried to do mass flash with my custom carrier boards By using below commands

  1. Command for generating the Mass flash Images.
sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 --no-flash --massflash 2  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml"   --showlogs --network usb0 jetson-orin-nx-jenner-flash internal

2.Command for flashing generated Mass flash Images

sudo ionice -c 1 -n 0 ./tools/kernel_flash/l4t_initrd_flash.sh --flash-only --massflash 2 --showlogs --network usb0

The problem is only one board getting flashed and another board is failing. I am using Ubuntu 22.04.4 Ubuntu 18.04
flash_logs.zip (8.6 KB)

Hi pippalla.chakravarthi,

What’s the Jetpack version in use?

[   0.4091 ] ERROR: might be timeout in USB write.
Error: Return value 3
Command tegrarcm_v2 --instance 3-4 --chip 0x23 0 --pollbl --download bct_mem mem_rcm_sigheader.bct.encrypt --download blob blob.bin
Cleaning up...

I’ve checked your fail log (flash_3-4_0_20240705-185529.log) and it seems timeout as above.
Please check the serial console log from this board.
You can also try to switch another USB cable.

What do you mean here?
Are you using Ubuntu 20.04 or 18.04 as your host PC?

Hi @KevinFFF ,

What’s the Jetpack version in use?

JP 5.1.2 L4T35.4.1

Yes i checked the log one board is failing because of timeout . Its getting into the bash and from there on its failing

d /lib/modules/5.10.120/kernel/drivers/hwmon/pwm-fan.ko 
[    8.542203] using random self ethernet address
[    8.542327] using random host ethernet address
[    8.545013] Mass Storage Function, version: 2009/09/11
[    8.545147] LUN: removable file: (no medium)
[    8.546254] LUN: removable file: (no medium)
[    8.547327] LUN: removable file: (no medium)
[    8.548446] LUN: removable file: (no medium)
Add /dev/nvme0n1
[    8.550953] rndis0: HOST MAC 1e:ce:a5:1e:b1:4b
[    8.551072] rndis0: MAC e2:74:8e:35:39:7c
[    8.551273] tegra-xudc 3550000.xudc: EP 0 (type: ctrl, dir: out) enabled
[    8.866850] tegra-xudc 3550000.xudc: EP 5 (type: intr, dir: in) enabled
[    8.867068] tegra-xudc 3550000.xudc: EP 3 (type: bulk, dir: in) enabled
[    8.867274] tegra-xudc 3550000.xudc: EP 2 (type: bulk, dir: out) enabled
[    8.867548] IPv6: ADDRCONF(NETDEV_CHANGE): rndis0: link becomes ready
[    8.867680] tegra-xudc 3550000.xudc: EP 7 (type: bulk, dir: in) enabled
[    8.867949] tegra-xudc 3550000.xudc: EP 4 (type: bulk, dir: out) enabled
[    8.987912] random: crng init done
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell
bash-5.0# 

You can also try to switch another USB cable.

Yes Tried to use different Standard USB cables still there is no progress

What do you mean here?
Are you using Ubuntu 20.04 or 18.04 as your host PC?

We have to host PC’s 22.04 and ubuntu 18.04 I tried from both PC’s

Why one board is flashing another board is failing to flash it gives timeout

I would like to check the full serial log from the failed board.

You can also compare the logs between both boards.