Orin nx module to jetpack5.1,custom board,nvme flash error

Hi, I have a problem with buying and flashing an orin nx 16gb module

I tried the following documentation

After mounting the ssd and applying power to recovery mode,
I entered the following command

sudo ./apply_binaries.sh // This step is a success
sudo ./tools/l4t_flash_prerequisites.sh // This step is a success
sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 p3509-a02+p3767-0000 internal

But I got the following message, no progress in resolving

Waiting for target to boot-up...
Cleaning up...

I am attaching the full log and will upload more logs if needed. Any help would be greatly appreciated
flog_0330.txt (244.2 KB)

Hi chw0507,

Are you using p3509 as your carrier board for your Orin NX module?

The Jetpack5.1.1(R35.3.1) is released, could you help to use the BSP package and instruction instead of nvidia_sdk/JetPack_5.1_Linux_JETSON_XAVIER_NX_TARGETS/ downloaded from SDKM?

Thank you so much for posting an answer.

I used two types of carrier boards: This is a p3509 board from nvidia devkit and a custom carrier board from leetop product(LeeTop)

Unfortunately, both boards received the rootfs of 35.2.1 / 35.3.1, so I flashed it through the command of Jetson Orin NX + Xavier NX Devkit (NVMe) in the course I first ran, but I got the same result.
(I attach the log flashed through 35.3.1)

flash_log_0331.txt (251.7 KB)

After struggling with this problem for several days, after installing the xavier nx module on two types of p3509 boards and applying (successfully) flashing the jetpack 5.1 in the SDK, removing the xavier module from the nvidia devkit and uploading the orin nx module, the flash( command in the terminal) It was successful, and the same orin nx module was installed on the board of the leetop product, and the flash failed.

Waiting for target to boot-up...

For this situation, you should check the serial console log to know why it cannot boot up.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.