Oscilloscope not showing CAN signal

I am working on a NVIDIA AGX machine for a project .I tried to send the packets from one controller to another but still couldn’t see any change in the ipconfig. Tried to observe the signal using oscillscope by transmitting messages from can0 to can1 but got some random signal not related to the required output.I have attached the image of the signal.I set the bitrate as 500000 and loopback works fine. is viewing the signal in an oscilloscope a good idea?
If it is not,then how can we view the signal from the controller?

Hi billakurthi.sivasai,

Are you using the devkit or custom board for AGX Xavier?
What’s your Jetpack version in use?

Loopback test for CAN with the following command is called internal loopback test for single bus, it doesn’t need to connect any external cable and should work fine.

ip link set can0 type can bitrate 500000 loopback on

If you want to transmit data from CAN0 to CAN1, then you need 2 CAN transceivers as the instruction mentioned.

Hi kevin,
1.We are using a dev-kit board
2.The current jetpack version is 5.1
3.We followed the same instructions and the physical connections are cross-verified. When we tried to transmit there were no packets transfer observed and the bus state is changed to Bus-OFF .
What i suspect is that maybe there would be some internal driver which should be triggered.

Please use latest JP5.1.1(R35.3.1) to verify.

The driver would be loaded when you run modprobe mttcan command.

Yeah even i tried it but still i couldn’t observe any data transmission from can0 to can1 or vice-versa.

When i have gone through the same problem faced by other people in the forums ,they have mentioned that for jetpack 4.6 or 4.4 everything works fine.

  1. Can an oscilloscope be used for observing the CAN signal ?
  2. Does CAN work with jetpack 5.1 version?

Do you open the duplicate topic for the same issue…?

How’s your connection to transmit data from CAN0 to CAN1?

It should work with JP5.1, but using latest JP5.1.1 could synchronize our status.

Similar issue but having some doubts regarding how to observe the signal .
Regarding the connection it is based on the diagram i attached below

Is it possible to view the signal using oscilloscope?

Hi, is y our connection correct? Basically the TX should be connected to RX of other CAN port. Also the waveform can be observed by probing the line/pin directly. Not sure why you can’t get that. But first you may need to check the connection based on data sheet of your trasciever.

Hi Trumany,
Yeah but when we verified with the connnection diagram with NVIDIA,they mentioned that it is correct.

I’m closing this topic due to there is no update from you for a period, assuming this issue was resolved.
If still need the support, please open a new topic. Thanks

Did you check the data sheet of transceiver? Can you share schematic of this part? And show which point you probed?