Xavier can read but cannot send CAN data

Hello ,
I have a problem with CAN communication on Nvidia Jetson Xavier, I had followed this tutorial :


I could read CAN data from CAN analyzer with candump, but I couldn’t send CAN data to CAN analyzer with cansend. And when I was reading CAN data with candump, stop reading, tried to send some data with cansend, it couldn’t receive any CAN data and sent fail also.
I had also tried to configure pins to CAN with pinmux, following this tutorial :

But there was the same problem.
CAN bus transceiver chip is VP230.
When I connected pins from nvidia to osciloscope, we tried to send some data with cansend and could not see any messages.
When I am testing on loopback mode, even I didn’t use wires to connect CAN0_DOUT to CAN0_DIN, and didn’t connect CAN1_DOUT to CAN1_DIN, why CAN0/CAN1could read CAN data twice with candump from CAN0/CAN1data with cansend.
Can you please help me to solve this problem ?
Thank you for your help

Hi gueij,
When loopback works fine means you have configured Jetson CAN correctly. High chance of the problem with transceiver or connections. I would recommend to check it once properly.
Also can you share any failure kernel logs if any. It will also be helpful if you send a setup picture of connections. Also, check transceiver limitations of bitrate and the one you have set.
Let me know the results.

Thanks,
Shubhi