OSX Install Missing MPI

Hello, just installed 19.1 professional edition on OSX Mojave, and mpich appears to be missing- On previous versions there was the /opt/pgi/osx86-64//mpi directory. Am I missing something here, or do I have to build it separately now?

You’ll have to build it separately now. We’ve stopped shipping and supporting builds of MPICH 3.3. bundled with PGI Workstation as of PGI 19.1. I got it to build with 19.1 on a mac with the following steps:

  1. Download and save the mpich-3.3.tar.gz source tarball from www.mpich.org.
  2. Unpack the source tarball:
tar xvzf mpich-3.3.tar.gz
  1. Change into the mpich-3.3 directory that was created after you unpacked the tarball:
cd mpich-3.3
  1. Create a new subdirectory called “build” and change into it:
mkdir build
cd build
  1. Ensure that PGI 19.1 is in your path, for example:
export PATH=/opt/pgi/osx86-64/19.1/bin:$PATH
  1. Run the MPICH 3.3 configure script as follows:
env CPP='pgcc -E' CC=pgcc CXX=pgc++ FC=pgfortran F77=pgfortran ../configure --enable-static --enable-shared --with-device=ch3:nemesis --with-thread-package=posix --with-pm=hydra --without-valgrind --disable-fast --prefix=/opt/mpich-3.3

(Substitute /opt/mpich-3.3 above with the directory where you plan to install MPICH 3.3.)7. Build MPICH 3.3:

make V=1 all
  1. Install MPICH 3.3 - note you may need to become root (via sudo) if you are installing it to a privileged location, otherwise the “sudo” portion is optional:
sudo make V=1 install
  1. MPICH 3.3 will now be installed to /opt/mpich-3.3, or whichever directory you specified to the --prefix argument to configure above. Add the bin subdirectory to your $PATH, e.g.
export PATH=/opt/mpich-3.3/bin:$PATH

And you should now be able to build and run MPI programs on your Mac with PGI 19.1.