P0 state for maximum performance on GTX1070

Hi,

I try to set my GTX1070 fixed to P0 state. But currently it stays with P2 even with 100% load of the GPU.

root@headlessharry:~# nvidia-smi
±----------------------------------------------------------------------------+
| NVIDIA-SMI 384.59 Driver Version: 384.59 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 1070 On | 00000000:01:00.0 On | N/A |
| 37% 61C P2 150W / 150W | 2550MiB / 8110MiB | 100% Default |
±------------------------------±---------------------±---------------------+

The system is an Ubuntu 16.04 and xorg.conf is set with CoolBits 31.

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “AllowEmptyInitialConfiguration” “True”
Option “Coolbits” “31”

root@headlessharry:~# uname -a
Linux headlessharry 4.4.0-87-generic #110-Ubuntu SMP Tue Jul 18 12:55:35 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Only thing I found on the internet was the following, but I didn´t change the P state at all.

root@headlessharry:~# nvidia-settings -a [gpu:0]/GPUPowerMizerMode=1

Attribute ‘GPUPowerMizerMode’ (headlessharry:1[gpu:0]) assigned value 1.

Cheers,
*p

By design.


https://devtalk.nvidia.com/default/topic/1010856/?comment=5186680

Ran across a discussion in github on this topic that suggests there is a way to force P0 state. Perhaps someone else in this thread might be able to figure out how to do this on a Linux box?

hi there ___ still any idea to get the p0 state constant in ubuntu gtx1080ti.
any way to force it?? or just to have a try how it is to run the card in p0 state?
thank you for an answer.