Package not loaded correctly

after installing the CUDA 5.0 and NSight 3.0 frameworks both Visual Studio 2010 and 2012 crash on start-up. Running VS 2010 in administrator mode reveals the error:

The ‘Nvda.Vsip:NvdaPackage, Nvda.Vsip.Net, …’ package did not load correctly.

Has anyone else experienced this and perhaps solved it?

I tried running VS 2010 with the commands ‘devenv /resetskippkgs’ and ‘devenv /resetsettings’ but to no avail.


I found the following workaround in administrator mode:
Copy the packages from the NSight 3.0 installation folder
(e.g. C:Program Files (x86)NVIDIA CorporationNsight Visual Studio Edition 3.0HostCommon)
to the extension folder of Visual Studio
(e.g. C:Program Files (x86)Microsoft Visual Studio 10.0Common7IDEExtensionsNVIDIANsight Visual Studio Edition3.0)

Hi Thomas,

We’ve seen some rare cases where registration of the packages fail in the installer. Usually reinstalling Nsight with Administrator privileges solves these issues.


I am having a very similar issue. I had NSight 2.2 working, then upgraded to 3.0, realised it doesnt support GeForce640 and so uninstalled it and went back to 2.2. Now 2.2 fails with exactly the message above. I am using the 64bit windows installer in Admin mode. Any suggestions?

Can I also ask if GEFORCE GT 640 is likely to be supported on Nsight3.0 in the near future? Thanks

The GeForce GT 640 should be supported in Nsight 3.0.

Try uninstalling Nsight 2.2, remove all other Visual Studio plugins, and then from Visual Studio command prompt type: devenv /resetsettings

After that, install the desired Nsight version.

In my case, uninstalling all CUDA toolkit and installing the Nsight first solved this problem.
There may be a race condition between toolkit 5.0 and Nsight 3.0.


Below steps worked for me,

  1. Uninstall existing Visual Studio & CUDA.
  2. Download latest Visual Studio and re-install.
  3. Download latest CUDA and re-install.