Pandas installation issue Python 3

I tried to install pandas on Xavier and it hangs at that below. I quit the installation with CTRL+C Any suggestions?

$pip3 install pandas

Collecting pandas
Using cached
Requirement already satisfied: python-dateutil>=2.5.0 in /usr/local/lib/python3.6/dist-packages (from pandas) (2.7.3)
Requirement already satisfied: pytz>=2011k in /usr/lib/python3/dist-packages (from pandas) (2018.3)
Requirement already satisfied: numpy>=1.9.0 in /usr/local/lib/python3.6/dist-packages (from pandas) (1.15.2)
Requirement already satisfied: six>=1.5 in /usr/lib/python3/dist-packages (from python-dateutil>=2.5.0->pandas) (1.11.0)
Building wheels for collected packages: pandas
Running bdist_wheel for pandas …

How long do you wait before you ctrl-C?

What is the machine doing when you ctrl-C, if you check in another window with “ps -a” or “top” or similar?

If you look at the tip of the process tree that your pip3 command is part of, what is that “tip” process doing? You could attach with strace and see if it’s waiting on something, or actually just doing a lot of work.


As snarky said, it may take some time to install certain python module.

Please try to reboot your device, maximize the device performance via jetson_clocks and try to install it again.

sudo ./


I let it run overnight last night and it worked. I have no idea how long it actually took.

1 Like


Just in case somebody else land here:
I ran in the same issue and indeed the only option is to be patient:

Just run this to realize how patient:

time pip3 install pandas

In my case the output was 27 minutes.