[Partially Solved] RTX 3070 Laptop won't resume after sleep / suspend on Lenovo Legion 5 (15ACH6H)

Since doing a fresh install of Arch Linux my system will not resume if the laptop is put to sleep for any reason. If connected to an external monitor, graphics will resume on the 2nd screen but remains blank on the primary laptop display. We have tested a similar laptop using the built-in GTX 1660 Ti with the same display configuration and this works perfectly. It’s another Lenovo Legion 5, pretty much the one from the year before my model. (Turing)
Is it possible that there is an issue with Driver issue with this GPU? Below are my full specifications of my laptop.

EDIT: I’ve tried deleting the X Org Config, result still the same.

Operating System: Arch Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.0-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 5800H with Radeon Graphics
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2

Thanks for any help you can give.

nvidia-bug-report.log.gz (288.5 KB)

Please check if this helps:

Hi, thanks for the quick reply and information. The issue isn’t with the screen brightness but instead more to do with what happens after the laptop resumes from sleep.

Please read that thread again, it’s about brightness control not working and the internal screen’s brightness set to zero on resume from suspend.

1 Like

Sorry! I just read through it again and added the kernel parameter to grub and rebooted. It seems to be working perfectly now, thanks a lot!

This solution works most of the time however if I run a Windows virtual machine when I shut it down it goes back to the lock screen where only the external monitor is working. Any ideas on how to fix this? It intermittently works but on the occasions when it fails I have to reboot the system or force the power off.

This rather sounds like the Xserver crashing on exiting the VM. Please create a new nvidia-bug-report.log afterwards.

Sure, I’ve attached a more recent bug report. When I’m having to force shut down the computer and then start Linux again sometimes the drivers completely glitch out the screen. Rebooting a couple times is the only way so far I’ve managed to fix this. I’ll try to attach a video showing the problem in greater detail.

nvidia-bug-report.log.gz (297.0 KB)

Apart from some odd Xorg backtrace where the nvidia driver seemingly didn’t load, there’s nothing to be found, I guess the last crash was too long ago. Please create a log right after crash and reboot.

nvidia-bug-report.log.gz (306.3 KB)

I have also added a link to the video where this is happening whenever I shutdown the VM.

Nothing that explains why the system is freezing after closing the vm. On the next boot, the nvidia driver doesn’t load so it falls back to fbdev simple vga which only supports one monitor. I guess the recovery mode might get auto-started.