Monitor wont wake up after suspend

After waking up my computer from sleep, both my monitors wont wake up.

Reproduction:

  1. Start Computer
  2. Computer boots successfully to X11 with i3 in my case
  3. Open terminal -> # systemctl suspend
  4. Computer goes to sleep
  5. Press power button to wake up computer
  6. Computer wakes up
  7. Monitors wont wake up (Display Port no Signal)

I can ssh into my computer. DPMS says monitor is on.

System:

  • Kernel: 4.9.6-1-ARCH x86_64 (64 bit)
  • Distro: Arch Linux
  • Desktop: i3 4.13
  • MoBo: ASUS Sabertooth Z77 (v 2104)
  • Graphics: NVIDIA GTX 980 Ti
  • Graphics driver: nvidia 375.26
  • Monitor: 2x ASUS PB287, DisplayPort 1.2, 3840x2160@60Hz

Workarounds not working

  • Blacklisting nouveau drivers
  • Manually DPMS force on

nvidia-bug-report.log (402 KB)

More trouble-shooting approaches:

(SOLVED) resume from suspend not working with 980 Ti, drivers 352 - 370, kernels 3.16 - 4.4 - NVIDIA Developer Forums
https://devtalk.nvidia.com/default/topic/919984/linux/-solved-resume-from-suspend-not-working-with-980-ti-drivers-352-370-kernels-3-16-4-4/

resume from suspend freezes system (GTX 970, Arch Linux, Kernel 4.4/4.7, NVIDIA 370) - NVIDIA Developer Forums
https://devtalk.nvidia.com/default/topic/962231/linux/resume-from-suspend-freezes-system-gtx-970-arch-linux-kernel-4-4-4-7-nvidia-370-/

Hi Domeee, In log I see :

When wakeup about to finish Xid 61 hit:

[  135.209836] NVRM: GPU at PCI:0000:01:00: GPU-0d19aa24-2219-7002-9603-96e9cacf4336
<b>[  135.209839] NVRM: Xid (PCI:0000:01:00): 61, 13a7(1a24) 00000000 00000000</b>
[  138.211386] nvidia-modeset: WARNING: GPU:0: Lost display notification (0:0x00000000); continuing.
[  142.212874] PM: resume of devices complete after 66913.643 msecs
[  142.218712] PM: Finishing wakeup.
[  142.218713] Restarting tasks ... done.

also

Feb 06 06:28:28 bellagio kernel: NVRM: Your system is not currently configured to drive a VGA console
Feb 06 06:28:28 bellagio kernel: NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
Feb 06 06:28:28 bellagio kernel: NVRM: requires the use of a text-mode VGA console. Use of other console
Feb 06 06:28:28 bellagio kernel: NVRM: drivers including, but not limited to, vesafb, may result in
Feb 06 06:28:28 bellagio kernel: NVRM: corruption and stability problems, and is not supported.

Please blacklist nouveau :

You can add Nouveau Driver in /etc/modprobe.d/blacklist.conf file. OR create file like /etc/modprobe.d/disable-nouveau.conf with below entries
blacklist nouveau
options nouveau modeset=0

And add kernel parameter : vga=0 rdblacklist=nouveau nouveau.modeset=0
Reboot

Is this issue repro with single display? Did you noticed Xid 61 after system wakeup ? What desktop env you are running KDE, GNOME, Unity or else?

Thank you very much JGB123321 for the inputs. I already tried all of the reasonable approaches mentioned in there. Sadly without success :-(

Thank you very much sandipt for your help, I really appreciate it.

The issue also occurs, if the error with Xid 61 does not appear. (see new log file attached)
Blacklisting nouveau drivers does not help. (see log file attached)
The issue also occurs if only one monitor is connected.

The issues only occurs on monitors connected via DP 2.1. I connected a second monitor via HDMI. The monitor connected via HDMI resumes from sleep - as expected.

I currently have no desktop installed, only I3 window manager. I also tested with KDE and XFCE. On both desktops the problem occurs. The issue does not occur on Windows.
nvidia-bug-report.log (425 KB)

I did a clean install of my system. I switched from BIOS to UEFI and therefore from GRUB to systemd-boot. With this change i was able to solve the following error:

Feb 06 06:28:28 bellagio kernel: NVRM: Your system is not currently configured to drive a VGA console
Feb 06 06:28:28 bellagio kernel: NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
Feb 06 06:28:28 bellagio kernel: NVRM: requires the use of a text-mode VGA console. Use of other console
Feb 06 06:28:28 bellagio kernel: NVRM: drivers including, but not limited to, vesafb, may result in
Feb 06 06:28:28 bellagio kernel: NVRM: corruption and stability problems, and is not supported.

After waking up from suspend the monitor still wont wake up. I can connect via ssh and was able to get the log (attached to this post) with the following error:

[  306.756551] nvidia-modeset: WARNING: GPU:0: Lost display notification (0:0x00000000); continuing.
[  310.757547] PM: resume of devices complete after 66765.566 msecs
[  310.758290] PM: Finishing wakeup.
[  310.758291] Restarting tasks ... done.
[  435.886212] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000957d:0:0
[  438.886482] nvidia-modeset: WARNING: GPU:0: Lost display notification (0:0x00000000); continuing.
[  442.846303] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000957d:0:0

nvidia-bug-report.log (447 KB)

Is this issue reproduce with 378.09? Is any old driver user help to resolve this issue from ftp://download.nvidia.com/XFree86/Linux-x86_64/

Thanks for your response. What’s the best way to try different nvidia driver versions? The system mentioned is my home (production) system and I don’t want to break it. For example, 378.09 requires xorg-server 1.19.1-3, i got xorg-server 1.19.1-2.

Thanks for you help!

Preferably from your distro in a form of packages.

The truth is 378.09 drivers don’t have any requirements in regard to X.org version (except maybe in the future they won’t support new X.org releases but it’s not yet happening).

I had the same issue with 375.26 drivers as Domee in the first post.
Upgrading to 378.13 solved the issue for me and I finally can use standby again.

I’m using a quite vanilla and up-to-date Sabayon distribution (they are still using 375.26) and I am now using the vanilla gentoo nvidia-drivers-378.13 ebuild

this helped with my NVIDIA Corporation GM204GLM [Quadro M3000M] (rev a1) card using ubuntu and
apt-get install nvidia-361 nvidia-cuda-toolkit python-pycuda-dbg
After suspend the computer slowed down to a crawl. blacklisting nouveau fixed it. thanks!!

Jorg

Hi Domeee, Did you test 384.47 (beta) and 378.13 driver? Looks like you are using ASUS PB287Q display with NVIDIA GPU GeForce GTX 980 Ti (GM200-A) , Did you see this issue with any other monitors connected via DP 2.1.? Is the issue reproduce without nvidia driver I mean with fresh os? Run nvidia-xconfig --mode-debug and start X then run nvidia bug report as soon as you observe the issue.

I have the same issue with my ASUS ROG PG279Q on Display Port on Linux.
My other monitor does not have this issue (an old Acer GD245HQ). It works fine after standby.

Steps to reproduce:

  • Log in into Unity or GNOME 3 (it does not matter if I use multi monitor setup or single monitor setup)
  • Go into standby mode
  • Wait until the ASUS ROG PG279Q also goes into standby mode (display backlight turns off)
  • Wake the PC up again
  • The ASUS ROG PG279Q wakes up, but displays “No Signal”

If I wakeup the ASUS ROG PG279Q (by accessing the monitor menu) before I wakeup the PC itself, it works.

I also tested it on Windows 10 which works without a problem.

The following driver versions were used:

  • The default Ubuntu 17.04 nvidia driver (I think version 375).
  • I also tested it on Version 384.59 (also Ubuntu 17.04)

If I use a multi monitor setup, only my old ACER GD245HQ monitor wakes up after standby.
I can see in the nvidia-settings screen that only my old monitor is detected. The ASUS ROG PG279Q just vanishes.

If I logout (which restarts X11 I think) both monitor work again.

nvidia-bug-report.log.gz (169 KB)

I just found a faster way to reproduce it, because it also happens if just the monitor is going to standby.

Steps to reproduce

  • Log in into Unity or GNOME 3 (it does not matter if I use multi monitor setup or single monitor setup)
  • sudo xset dpms force off
  • Wait until the ASUS ROG PG279Q also goes into standby mode (display backlight turns off)
  • Press any button to wake up the monitor.
  • The ASUS ROG PG279Q wakes up, but displays “No Signal”

System:

Kernel: Ubuntu 4.10.0-28-generic (64 bit)
Distro: Ubuntu 17.04
Desktop: i5-6600
Motherboard: Gigabyte Z170 HD3P (v1)
Graphics: NVIDIA GTX 1070
Graphics driver: NVIDIA 384.59
Monitor: ASUS ROG PG279Q

When waking from a long standby, one of my two Asus ROG Swift PG279Q displays would not wake about 30% of the time.

Thus far, turning off “DisplayPort Deep Sleep” in the display’s setup menu seems to have corrected the issue. Although ON is the default factory value for these settings, the User Guide states:

It is recommended that you set the DisplayPort Deep Sleep and HDMI DeepSleep functions to “OFF”

Kernel: 4.11.9
Distro: Fedora 26
Driver: 384.59
GPU: GTX 1080 Ti
Display: 2x Asus ROG Swift PG279Q

4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
driver 384.111

all nouveau eliminated.

The common problem of stop after resume from S3

machine T440p

it crashes on resume with a little "-"in the topleft corner of the screen

WILLING TO DO TESTS

@jean-pierre.eckmann:
This thread is about a different issue, please open a new thread. Run nvidia-bug-report.sh and attach the tar.gz file it creates to your post. See if you can switch to VT, suspend-resume, then login to VT and run the script.

Hey everyone. I posted a solution here: https://devtalk.nvidia.com/default/topic/1070352/linux/solution-for-nvidia-sleep-wake-issue/post/5422587/

I should mention that I’ve tried everything since 2010 on several laptops and the above is the only thing which ever worked because it actually tests your computer’s capabilities and offers you the proper line for GRUB. Everything else I’ve seen so far has been the equivalent of pinning a tail on a donkey blindfolded.

Fabulous, I think turning off these “deep sleep” options resolved the issue for me (same monitor with Ubuntu 20.04, running GDM3, nvidia-driver-450 [450.66]).

1 Like