Disable of HDMI-0 on ubuntu 18.04

Hi all,

I’m on an MSI gs65 8sf, when I suspend the laptop, the port HDMI-0 stops working, and for reactivate it I need to reboot on windows wait 10 minutes and then come back on linux.

I tried to find the solution alone and I found that post that seems to be my exact problem, unfortunately the solution proposed here does not work (and it brakes another work around that I did for making working the airplane mode button).

I attached my nvidia-bug-report that I did after suspending the pc while the external monitor is connected but it’s in sleep mode because it does not receive any input.

I tried with different monitors and with everyone the result is the same.

nvidia-bug-report.log (2.0 MB)

Does it work if you remove the acpi_osi parameters?

Hi,
No, the problem is still the same.
I’m loading the new bug report just to show if there is some differences.

I realized a new thing: If I use I3 (the problem is present with every desktop environment and every display manager) and I reload i3 after the suspend it crashes and I have to log out and log in again to make work even the first monitor. but the second is still not working.nvidia-bug-report.log (2.0 MB)

Another thing that I want to add is that when I run windows it does not fix the monitor immediately, it require time (~10 minutes) without anything connected to the HDMI port.

I updated ubuntu to the version 20.04 LTS, the problem persists.

I found out that if I turn off the pc (no reboot but shutdown) and then I turn it on again, the second monitor is been reactivated.

Hi all,

I’m trying to make this post awake again because I didn’t find the dolution yet.

Do someone know how to fix it?