Particle cloth attach with franka robot failed


I am currently trying to attach the particle cloth object to the gripper of factory franka robot but it crashed when I click start. you can see the described behavior in the link below.

And, later I add the rigid cube as the fiexed joint of robot gripper and set attachment of particle cloth and the cube. the fixed joint setting is ok but the attachment of particle cloth and cube make simulator crash again. The operation is described in the link below.

Then, I make the cube as the deformable body and attach to robot gripper and particle cloth, it seems like works, but the shape of the deformable cube keeps changing.

Does anyone know what the cause of this and how to repair it?

In the attached usd file I used in the video (105.3 KB)

are u using standalone python? im just wondering how to simulate franka in gpu pipeline due to particle could only be simulated in gpu pipeline

This video is just the result of my operation in the simulator, I did not write any code about this video. Maybe you can look at some sample codes to solve your problem.

Hi @wang_ruiqiang,
I tried to load your repro stage but “factory_franka” and “garment” references are missing. Not sure what’s going on, but we don’t support attachments to rigid bodies that are part of articulations (we are just adding that now). Maybe you need to tweak the rest/contact offset of that deformable, I think by default it is 2 cm, or something like that.

Thank you for your reply @SimonPhysX .

I reupload the new zip with these two object. In the zip you can open “cube_as_deformable_object.usd” and “cube_as_fixed_joint.usd” to see the differences of these two usd file.

In the “cube_as_deformable_object.usd” , I use “Cube_01” as the deformable body, and it can attach with franka and garment, but because it is deformable body, the shape of “Cube_01” is not stable when the world start running.

In the "“cube_as_fixed_joint.usd”, I use “Cube_01” rigid body and create “fixed joint” with it and franka. Then create attachment with “Cube_01” and garment. But it crashed when world runs.

So as you say, Isaac sim don’t support attachments to rigid bodies that are part of articulations, but it can actually attached with deformable body and cannot attach with particle cloth, is it right? (9.3 MB)

I don’t have any definitive answers for you but here are some findings:

  • I was able to reproduce the crash with cube_as_fixed_joint.usd, and it is fixed in our latest not yet released version.
  • I thought we didn’t support deformable body attaching to rigid bodies that are part of an articulation, but apparently it does work under some circumstances. Again in the not yet released version in should work in all cases.
  • I was able to tweak the attached deformable to behave much better by lowering the contact and rest offsets a lot.
  • The main reason the T-shirt can’t be picked up is because it’s too heavy in comparison to the deformable/robot parts. I had some issues tweaking the cloth mass, and I will be looking into that issue.
1 Like

Thank you very much for your reply, it is useful. @SimonPhysX

Could I ask when the version that fixes this problem will be released? and the name of the version?

For the cloth mass, in the usd, I also tried to change the mass of the cloth and it was able to perform differently. In the usd file, I give the mass of the cloth to 0.2kg, which should be similar to the mass of clothes in daily life. If this weight is too heavy compared to the deformable/robot parts, there may actually be some problems.

1 Like