PCIE still no power with JL35.1

I have found many topics about Orin PCIE power in this forums, some of them are about JL 34.1. Since I’m using JL35.1 and my situation is similar with the topic below, I also changed power mode to MAXN, but PCIE still not powered.

AGX Orin Devkit PCIE Power JL 35.1

I have spent two days on it, and now have no ideas, please help me!

More information:

Do the full reflash instead of putting any “dtbo” in /boot. That won’t take effect.

I installed JL 35.1 directly through SDK Manager, as you said, the fix is already included in JL 35.1, should I do a full reflash? If yes, please tell me how to do it, thanks.

No… I mean you need to put that fix (dtbo) to your BSP folder and do full flash instead of just randomly put it on somewhere of your board.

I am not saying that 35.1 having that fix or not…

emm… I didn’t have a “fixed dtbo” actually. Because I have checked the /boot/tegra234-p3737-overlay-pcie.dtbo after installed JL 35.1, it matched the requirement you mentioned here AGX Orin Devkit PCIE Power JL 35.1 - #5 by WayneWWW, both ids and GPIO H,4.

In addition, “JL 35.1 having the fix” is from here AGX Orin Devkit PCIE Power JL 35.1 - #3 by WayneWWW

Could you check if that change is really loaded on your modue? You could check /proc/device-tree.


Looks like loaded, is the pcie_ep@141a0000 ?

No. I mean the regulator change.

How to make a regulator change and ensure it is loaded?

Returning to the origin: Is there an official guide about power up PCIE on JL 35.1?

@WayneWWW Hi, any update for this question?

please directly try rel-35.2 which must have that patch.

Hi, WayneWWW,

I have flashed JetPack 5.1 to my AGX Orin, which includes Jetson Linux 35.2.1, however, the PCIE still not powered.

I also checked dmesg, found the same error message with JL 35.1 previous showed:

[   11.633424] tegra194-pcie 141a0000.pcie: Failed to get slot regulators: -517

What should I do next?


Then your issue has nothing to do with that patch. It is something else. You can just ignore that error. The issue is not related to power.


I have pushed the PCIE card to my PC, the LED power indicator lights on and “lspci” enumerates it.

But on Orin, the indicator only lighted for a moment during start time, suddenly turn off before Desktop showed.

Based on the above phenomena, I guess it related to PCIE power supply.

Are you using Orin AGX devkit or something else?

It’s Orin AGX devkit.

What kind of pcie device is in use? Which slot are you using?

I’m using PCIE to extend storage, there are two SAMSUNG 980PRO 1TB SSD on it.

Is there any other pcie device that can test instead of this one?

Although no one at hand, I will do the test.