pgf on Mac OS mavericks

My pgf90 12.10-0 installation seems to be broken after upgrading to mac os x 10.9. Part of the upgrade included upgrading to Xcode 5

Here are error messages:
ld: warning: directory not found for option ‘-L/Applications/Xcode.app/Contents/Developer/usr/llvm-gcc-4.2/lib/gcc/i686-apple-darwin11/4.2.1/x86_64’
ld: warning: directory not found for option ‘-L/Applications/Xcode.app/Contents/Developer/usr/llvm-gcc-4.2/lib/gcc/i686-apple-darwin11/4.2.1’
ld: file not found: /usr/lib/crt1.o

Is there an easy fix?

Thanks for helpful advice.

Hi apd,

My pgf90 12.10-0 installation

Do you mean 13.10? 12.10 was released over a year ago and wont work on Maverick or with XCode 5.

Since Maverick was released just before we shipped 13.10, we don’t officially support it. (See: http://www.pgroup.com/support/install.htm#osx_info). However, if you are just upgrading to OSX 10.9 from 10.8, then our testing shows that everything should work fine with PGI 13.10. The installation problems we’re seeing are with fresh OSX 10.9 installations. If this is the case with you, please contact PGI Customer Service (trs@pgroup.com) since we do have a work around.

  • Mat