(pgroupd) DENIED problem

Dear all,

I installed a 64bit version of pgi compilers version 10.8. During a compilation I receive a lot of messages like these:
13:30:28 (pgroupd) DENIED: “pgi-f95-lin64” root@test.it (INVALID error code (-9999,333))
13:30:28 (pgroupd) OUT: “PGI2010-workstation-complete” root@test.it
13:30:28 (pgroupd) OUT: “pgi-f95-lin64” root@test.it
13:30:28 (pgroupd) IN: “pgi-f95-lin64” root@test.it
13:30:28 (pgroupd) IN: “PGI2010-workstation-complete” root@test.it
13:30:28 (pgroupd) DENIED: “pgi-f95-lin64” root@test.it (INVALID error code (-9999,333))
13:30:28 (pgroupd) OUT: “PGI2010-workstation-complete” root@test.it
13:30:28 (pgroupd) OUT: “pgi-f95-lin64” root@test.it
13:30:28 (pgroupd) IN: “PGI2010-workstation-complete” root@test.it
13:30:28 (pgroupd) IN: “pgi-f95-lin64” root@test.it

The compilation ends fine, but I don’t understand the reasons for these messages.
Some could help me?

Thanks
Enrico

Hello,

Is the license file on a local drive? If you move it there,
does the behavior change?

We do see behavior like this on NFS mounted drives sometimes.

thanks,
dave

Yes, the license file is on local drive.

I experience the same error. I’m running it on local drive

The issue in my case has been due to software installation and setup.

Changing the license type from stand-alone to network solved my problem.

Now it compiles smooth

17:49:36 (pgroupd) DENIED: “pgi-f95-lin64” root@Xi-Neural-Net (INVALID error code (-9999,333))
17:49:36 (pgroupd) OUT: “PGI2014-workstation-fortran” root@Xi-Neural-Net
17:49:36 (pgroupd) OUT: “pgi-f95-lin64” root@Xi-Neural-Net
PGF90-F-0004-Unable to open MODULE file cula.mod (func.f: 1)
PGF90/x86-64 Linux 14.9-0: compilation aborted
17:49:36 (pgroupd) IN: “pgi-f95-lin64” root@Xi-Neural-Net
17:49:36 (pgroupd) IN: “PGI2014-workstation-fortran” root@Xi-Neural-Net
root@Xi-Neural-Net:/opt/nn/s4#

Hi Shannon,

It looks like the error here is that the compiler can’t find the CULA module. Can you please check if it’s available and in your include path?

  • Mat