Problems with license

Hello,

I’m trying to configure a server license for a network installation. Server will run FlexLM server and will serve a NFS shared folder where I will install PGI. Clients will mount that NFS folder and will be able to use PGI software.

My license.dat is:
SERVER MYSERVER 002590364ff4 27000
DAEMON pgroupd
PACKAGE PGI2015-701447 pgroupd 2016.1207 6BCA317EF12D
COMPONENTS=“pgfortran pgcc pgc++” OPTIONS=SUITE SIGN=“075F
2D87 7324 1639 0A7F 3AF6 439D FFDD 0F70 14DC FFC6 CAAB 99A7
64CC AF12 0B70 CDE5 CCE2 D54C 6428 1DDF D4B8 930E FBE9 17A3
0403 6460 88EE 2705 8C3A”
FEATURE PGI2015-701447 pgroupd 2016.1207 7-dec-2016 1 E7E39D20BBE5
VENDOR_STRING=701447:4 HOSTID=002590364ff4 PLATFORMS=“unidev
v15.7 nv lin-acc” DUP_GROUP=UH SUITE_DUP_GROUP=UH SIGN=“0EAE
09FB 2998 9052 19F5 337C EA2A BB04 6372 6E82 A6D2 D3AC 7D45
32DE 7FA4 040C 70BF C9A8 D9DE D8FE B7F9 74AB 27A0 686A 8B4C
A3BC E95D 3B79 CC60 9A2D”



NFS shared folder, from the server side, is /exports/software/SL-6.4-x86_64/. That folder is mounted in client side as /soft.

I have installed PGI from a client that has mounted /soft. Then, installation will go to /soft/openACC-2015 folder (so in server side this folder will be /exports/software/SL-6.4-x86_64/openACC-2015).


I have started a flexLM server for PGI license that is listening on port 27000. I can check it with:
[root@MYSERVER ~]# /etc/init.d/flexlm-OpenACC status
lmstat - Copyright © 1989-2013 Flexera Software LLC. All Rights Reserved.
Flexible License Manager status on Fri 1/8/2016 14:43

License server status: 27000@MYSERVER
License file(s) on MYSERVER: /opt/flexlm-OpenACC/license.dat:

MYSERVER: license server UP (MASTER) v11.11

Vendor daemon status (on MYSERVER):

pgroupd: UP v11.11
Feature usage info:

Users of PGI2015-701447: (Total of 1 license issued; Total of 0 licenses in use)

Users of pgfortran: (Total of 1 license issued; Total of 0 licenses in use)

Users of pgcc: (Total of 1 license issued; Total of 0 licenses in use)

Users of pgc++: (Total of 1 license issued; Total of 0 licenses in use)


On the client side, after loading some environment modules, I’m exporting LM_LICENSE_FILE with value 27000@MYSERVER

Communication between client and server is OK (there are no firewalls), but when from client I run “pgcc -v diffACC.c -o diffACC”, I get this message:

[user@client Diffusion]$ pgcc -v diffACC.c -o diffACC
Export PGI=/soft/OpenACC-2015

/soft/OpenACC-2015/linux86-64/15.10/bin/pgc diffACC.c -opt 1 -x 119 0xa10000 -x 122 0x40 -x 123 0x1000 -x 127 4 -x 127 17 -x 19 0x400000 -x 28 0x40000 -x 120 0x10000000 -x 70 0x8000 -x 122 1 -x 125 0x20000 -x 117 0x1000 -quad -x 59 4 -tp nehalem -x 120 0x1000 -astype 0 -stdinc /soft/OpenACC-2015/linux86-64/15.10/include-gcc44:/soft/OpenACC-2015/linux86-64/15.10/include:/usr/local/include:/usr/lib/gcc/x86_64-redhat-linux/4.4.7/include:/usr/include -def unix -def __unix -def unix -def linux -def __linux -def linux -def __NO_MATH_INLINES -def LP64 -def __x86_64 -def x86_64 -def LONG_MAX=9223372036854775807L -def ‘SIZE_TYPE=unsigned long int’ -def ‘PTRDIFF_TYPE=long int’ -def __THROW= -def extension= -def amd_64__amd64 -def __k8 -def k8 -def SSE -def MMX -def SSE2 -def SSE3 -def SSSE3 -predicate ‘#machine(x86_64) #lint(off) #system(posix) #cpu(x86_64)’ -cmdline ‘+pgcc diffACC.c -v -o diffACC’ -x 123 0x80000000 -x 123 4 -x 2 0x400 -x 119 0x20 -def __pgnu_vsn=40407 -alwaysinline /soft/OpenACC-2015/linux86-64/15.10/lib/libintrinsics.il 4 -x 120 0x200000 -x 70 0x40000000 -y 163 0xc0000000 -x 189 0x10 -y 189 0x4000000 -x 198 0x40000 -asm /tmp/pgccAc7eop5c4Gm4.s
pgcc: LICENSE MANAGER PROBLEM: No such feature exists.
Feature: pgi-cc-lin64
License path: 27000@MYSERVER:/soft/OpenACC-2015/license.dat:
FlexNet Licensing error:-5,412
For further information, refer to the FlexNet Licensing documentation,
available at “www.flexerasoftware.com”.
pgcc-Fatal-ccompile completed with exit code 1

Unlinking /tmp/pgccAc7eop5c4Gm4.s
Unlinking /tmp/pgccQc7e_idpGxU4.ll


In server, lmgrd.log shows it:
14:44:30 (pgroupd) UNSUPPORTED: “pgi-cc-lin64” (PORT_AT_HOST_PLUS ) user@client (License server system does not support this feature. (-18,327))



Why? Where is, exactly, the problem?

Thanks

The unidev licenses are node locked.
The license service must run on the same one machine that is running
the compilers. MYSERVER must have the compilers installed, and
the resulting executable foo.exe from linking will only execute on MYSERVER.
So MYSERVER should have the GPU you are using.

The pgroupd version you should be using is 11.11.1.1 . It is necessary
on newer Linux versions with newer network device names.

Try putting the license file on a local disk on MYSERVER or whatever machine you are running the compilers on. If it works, then the problem
is partly an issue of the proximity of the license file, from the license service.

dave

Thanks about your answer.

I will try to get another license type (floating??) for allowing serve licenses in my scenario (a server that is serving licenses and the shared NFS folder where PGI is installed and a couple of clients importing that NFS folder and executing compilers from that NFS folder).

License server (and service) is running in MYSERVER and MYSERVER owns the NFS folder, but I execute compilers from a client (not MYSERVER) after mounting the NFS folder (the installation folder). So I can say that compilers are installed in MYSERVER, but MYSERVER has no GPU (GPUs are in the clients).

About pgroupd version, my server is running 11.11.1.1, so I suppose it is corrent, isn’t it? What did you mean with your comment?


Any more help?

Hi,

What is the latest update on this? Were you able to troubleshoot? I am interested because I am also facing the same issue.

\

Regards,
Ajay Mishra
Webworld Experts Reviews

The Unidev license you are using is no longer supported.
It only worked on the host where the license service was, and the executables created also only ran on that machine.

It expired in December of 2016.

The current flexlm version we use is 11.13.1.3, and our 17.* releases
are using new file formats that will require using the new versions.

I suggest you download the Community Edition, which has fewer
restrictions than the University Development edition license. It also
does not require a license service running. It has a license that comes
with the download. Just install the compilers and run.

http://www.pgroup.com/products/community.htm

is where to find this 17.4 free version. Executables run everywhere.

dave