License fails to check out on the server.

I am trying to install the PGI Workstation compilers on a machine that is running Red Hat Enterprise. I have downloaded and installed the compilers according to the Installation notes, set up all the enviroment variables (as root), and then set up the env. var. as the user who will be compiling.

The problem is as follows:
The machine that will compile the code needs to check the license against the server that is running FlexLM. It has a floating license and should be able to check out the machine that wants to compile (I know this, because another machine is set up to do this and it works perfectly fine), but everytime I try to compile, it gives the error:

pgf77-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license
pgf77-linux86: LICENSE MANAGER PROBLEM: Invalid (inconsistent) license key.
The license key and data for the feature do not match.
This usually happens when a license file has been altered.
Feature: pgf77-linux86
License path: 1234@server:/usr/pgi/license.dat
FLEXnet Licensing error:-8,130
For further information, refer to the FLEXnet Licensing End User Guide,
available at "> www.macrovision.com> ".
utsubs.f:
pgf77-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license
pgf77-linux86: LICENSE MANAGER PROBLEM: Invalid (inconsistent) license key.
The license key and data for the feature do not match.
This usually happens when a license file has been altered.
Feature: pgf77-linux86
License path: 1234@server:/usr/pgi/license.dat
FLEXnet Licensing error:-8,130
For further information, refer to the FLEXnet Licensing End User Guide,
available at "> www.macrovision.com> ".

I’m not sure what I’m doing wrong, because the machine I am setting up looks exactly like one that is already set up (no, I didn’t set up that one), but it doesn’t work. This is what the exports look like:

declare -x G_BROKEN_FILENAMES=“1”
declare -x HISTSIZE=“1000”
declare -x HOME="/home/user"
declare -x HOSTNAME=“xxx.xxx.xxx.xxx”
declare -x INPUTRC="/etc/inputrc"
declare -x KDEDIR="/usr"
declare -x LANG=“en_US.UTF-8”
declare -x LESSOPEN="|/usr/bin/lesspipe.sh %s"
declare -x LM_LICENSE_FILE=“1234@server:/usr/pgi/license.dat”
declare -x LOGNAME=“xxx”
declare -x LS_COLORS=“no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:.cmd=00;32:.exe=00;32:.com=00;32:.btm=00;32:.bat=00;32:.sh=00;32:.csh=00;32:.tar=00;31:.tgz=00;31:.arj=00;31:.taz=00;31:.lzh=00;31:.zip=00;31:.z=00;31:.Z=00;31:.gz=00;31:.bz2=00;31:.bz=00;31:.tz=00;31:.rpm=00;31:.cpio=00;31:.jpg=00;35:.gif=00;35:.bmp=00;35:.xbm=00;35:.xpm=00;35:.png=00;35:.tif=00;35:”
declare -x MAIL="/var/spool/mail/root"
declare -x OLDPWD="/usr/pgi/linux86/6.0"
declare -x PATH="/usr/pgi/linux86/6.0/bin/:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin"
declare -x PGI="/usr/pgi"
declare -x PWD="/home/xxx/xxx/xxx/xxx"
declare -x QTDIR="/usr/lib/qt-3.3"
declare -x SHELL="/bin/bash"
declare -x SHLVL=“2”
declare -x SSH_ASKPASS="/usr/libexec/openssh/gnome-ssh-askpass"
declare -x SSH_CLIENT="::ffff:xxx.xxx.xxx.xxx xxxxx xxx’
declare -x SSH_CONNECTION="::ffff:xxx.xxx.xxx.xxx xxxxx xxx:ffff:xxx.xxx.xxx.xxx xxxxx xxx’
declare -x SSH_TTY="/dev/pts/2"
declare -x TERM=“xterm”
declare -x USER=“xxx”

(I x’d out the information that I do not wish to disclose, but left the correct format nonetheless)

So, from what I understand, I am exporting everything correctly, but for some reason, the license fails.

Any suggestions would be highly appreciated.

Thanks so much.

Send trs@pgroup.com a mail with:

Your current license.
The output of “$PGI/linux86/6.0/bin/lmutil lmhostid”
Tell us if the license server is the same machine as the ones with the compilers installed.

Thanks!

The machine is not the same as the server holding the license. One machine is running FlexLM license manager with the current license, and I’m trying to set up a different machine to check the license against the server so that it can compile locally.

I have emailed trs already.

hope this helps.