No lmhostid?

Hi there,

I just wanted to install the PGI trial, the license manger is running, but the client cannot check out the license.

pgcc -V x.c

pgcc 7.0-4 32-bit target on x86 Linux
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2007, STMicroelectronics, Inc. All Rights Reserved.
pgcc-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license

However in the flexlm.log I get many errors like:
4:40:39 (pgroupd) Invalid license key (inconsistent authentication code)
14:40:39 (pgroupd) ==>FEATURE pvfdbg-win32 pgroupd 7.0 7-jun-2007 uncounted
********************** VENDOR_STRING=TRIAL:4:ws
14:40:39 (pgroupd) Server started on for: pghpf-linux86-64
14:40:39 (pgroupd) pgf90-linux86-64 pgf77-linux86-64 pgcc-linux86-64
14:40:39 (pgroupd) pgcpp-linux86-64 pghpf-linux86 pgf90-linux86
14:40:39 (pgroupd) pgf77-linux86 pgcc-linux86 pgcpp-linux86
14:40:39 (pgroupd) pgf90-win64 pgf77-win64 pgcc-win64
14:40:39 (pgroupd) pgcpp-win64 pgf90-win32 pgf77-win32
14:40:39 (pgroupd) pgcc-win32 pgcpp-win32 pgprof
14:40:39 (pgroupd) pgdbg pgdbg-gui pgdbg-linux86-64
14:40:39 (lmgrd) pgroupd using TCP-port 47240

(I’m using the full workstation package)

After a bit of reading I found that running “lmutil lmhostid” should help me find the right hostid, however I get:
lmutil lmhostid
lmutil - Copyright © 1989-2004 by Macrovision Corporation. All rights reserved.
The FLEXlm host ID of this machine is “”

Is this likely the problem? If so, can it be that this is caused by mine computer having no eth0 but starting at eth1?

Any suggestions would be welcomes, since I’m not sure where to poke around.


Hi Carsten,

The trial license is node-locked, meaning for use on a single system, and doesn’t work with FlexLM. Instead, please set your “LM_LICENSE_FILE” environment variable to the full path of your tiral license.

  • Mat

Let’s see, fresh start:

$ cat /opt/pgi/setenv
export PGI=/opt/pgi
export PATH=$PGI/linux86/7.0/bin:$PATH
export MANPATH=$PGI/linux86/7.0/man
export LM_LICENSE_FILE=$PGI/license.dat

-rw-r–r-- 1 root root 3404 2007-05-23 14:40 /opt/pgi/license.dat

$ head -n6 $LM_LICENSE_FILE
DAEMON pgroupd /opt/pgi/linux86/7.0/bin/pgroupd
SERVER 001641591484 27000
FEATURE pghpf-linux86-64 pgroupd 7.000 7-jun-2007 0
HOSTID=001641591484 ck=86
FEATURE pgf90-linux86-64 pgroupd 7.000 7-jun-2007 0 \

(I had tried it first with the auto-generate file containing no DAEMON line and SERVER ANY ANY 27000, same result)

$ cat x.c
int main ()
printf ( “Hello\n” );
return 0;

Trying to compile:
$ pgCC -v x.c

/opt/pgi/linux86/7.0-4/bin/newcg/pgcpp1 --nollalign -Dunix -D__unix -D__unix__ -Dlinux -D__linux -D__linux__ -Di386 -D__i386 -D__i386__ -D__NO_MATH_INLINES -Dlinux86 -D__THROW= -D__extension__= -D__SSE__ -D__MMX__ -D__SSE2__ -D__PGI -D__linux86 -D__signed__=signed -I/opt/pgi/linux86/7.0-4/include/CC -I/opt/pgi/linux86/7.0-4/include -I/usr/local/include -I/usr/lib/gcc/i486-linux-gnu/4.1.2/include -I/usr/lib/gcc/i486-linux-gnu/4.1.2/include -I/usr/include -q -o /tmp/ x.c

/opt/pgi/linux86/7.0-4/bin/newcg/pgcpp2 x.c -opt 1 -x 119 0xa10000 -x 119 0x100000 -x 122 0x40 -x 123 0x1000 -x 127 4 -x 127 16 -x 119 0x40000000 -x 19 0x400000 -x 28 0x40000 -x 70 0x8000 -x 122 1 -x 59 4 -tp piv -x 119 0x8000000 -astype 0 -fn x.c -il /tmp/ -x 123 4 -x 123 0x80000000 -alwaysinline /opt/pgi/linux86/7.0-4/lib/ 4 -cmdline ‘+pgCC /tmp/ -v’ -asm /tmp/pgCCAlfdoKKmwenP.s
pgcpp-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license
pgCC-Fatal-cpp2 completed with exit code 1

Unlinking /tmp/
Unlinking /tmp/pgCCAlfdoKKmwenP.s

I’ve run strace on the process; it reads the license.dat file fine, but just terminates in the end.

Any hint?

Hi Carsten,

My appologies, I should have read your first mail more closely. The fact that you don’t have eth0 set-up is the problem since this is what FlexLM uses to determine the hostid. Please send a note to and customer service can send you a general temporary license instead of the node-locked trial license.


No need to apologize, thanks a lot for your help, I’ll send out the email asap :)